Bug 158388 - yum misreports update errors
yum misreports update errors
Status: CLOSED DUPLICATE of bug 158392
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2005-05-21 09:26 EDT by Avi Kivity
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-06-19 02:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2005-05-21 09:26:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
due to some selinux problem, rpm scriplets do not execute for me: 
 Package                 Arch       Version          Repository        Size 
 openssh-server          x86_64     4.0p1-3          development-loca  222 k 
Transaction Summary 
Install      0 Package(s) 
Update       1 Package(s) 
Remove       0 Package(s) 
Total download size: 222 k 
Is this ok [y/N]: y 
Downloading Packages: 
Running Transaction Test 
Finished Transaction Test 
Transaction Test Succeeded 
Running Transaction 
error: %pre(openssh-server-4.0p1-3.x86_64) scriptlet failed, exit status 255 
error:   install: %pre scriptlet failed (2), skipping openssh-server-4.0p1-3 
Updated: openssh-server.x86_64 0:4.0p1-3 
but yum says the package has been updated, while it was not: 
[avi@blast ~]$ rpm -q openssh-server 
this misreporting is confusing and potentially dangerous 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. update a package that fails its pre-install script  

Actual Results:  yum reported the package as updated   

Expected Results:  yum should have warned that the package was not updated 

Additional info:
Comment 1 Seth Vidal 2005-06-19 02:53:18 EDT

*** This bug has been marked as a duplicate of 158392 ***

Note You need to log in before you can comment on or make changes to this bug.