Bug 1584084 - etcd_image_exists is undefined while scaling up masters
Summary: etcd_image_exists is undefined while scaling up masters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-30 08:58 UTC by Gan Huang
Modified: 2018-07-30 19:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:17:40 UTC

Description Gan Huang 2018-05-30 08:58:45 UTC
Description of problem:

While performing masters scaling up, installer failed at:
TASK [openshift_control_plane : Check status of etcd image pre-pull] ***********
fatal: [ec2-34-229-102-29.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "The conditional check 'etcd_image_exists.stdout_lines == []' failed. The error was: error while evaluating conditional (etcd_image_exists.stdout_lines == []): 'etcd_image_exists' is undefined\n\nThe error appears to have been in '/home/slave2/workspace/Run-Ansible-Playbooks/private-openshift-ansible/roles/openshift_control_plane/tasks/main.yml': line 156, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: Check status of etcd image pre-pull\n  ^ here\n"}

Version-Release number of the following components:
openshift-ansible-3.10.0-0.54.0.git.0.537c485.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Trigger HA installation 
2. Scaling up masters against the cluster above


Actual results:
see above

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Gan Huang 2018-05-30 09:01:11 UTC
The issue is that local fact `etcd_image_exists` only exists on etcd host, installer would fail if the master has no etcd role.

Comment 2 Scott Dodson 2018-05-30 13:46:36 UTC
Lets only check for this image on control plane hosts that are etcd hosts.

Comment 3 Vadim Rutkovsky 2018-05-30 14:57:58 UTC
Created https://github.com/openshift/openshift-ansible/pull/8573 to fix this

Comment 5 Gan Huang 2018-06-06 07:20:45 UTC
Verified in openshift-ansible-3.10.0-0.58.0.git.0.d8f6377.el7.noarch.rpm

The task is skipped as expected.

Comment 7 errata-xmlrpc 2018-07-30 19:16:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.