Bug 1584117 - should give message for nfs is an unsupported type for openshift_hosted_registry_storage_kind during upgrade from OCP 3.9 to 3.10
Summary: should give message for nfs is an unsupported type for openshift_hosted_regis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-30 10:29 UTC by Weihua Meng
Modified: 2018-07-30 19:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:17:40 UTC

Description Weihua Meng 2018-05-30 10:29:50 UTC
Description of problem:
should give message for nfs is an unsupported type for openshift_hosted_registry_storage_kind during upgrade from OCP 3.9 to 3.10

for fresh install OCP 3.10, we can get message about it.
TASK [Run variable sanity checks] **********************************************
Wednesday 30 May 2018  06:00:25 -0400 (0:00:00.853)       0:00:33.435 ********* 
fatal: [qe-wmeng310nfs-master-etcd-nfs-1.0530-7vd.qe.rhcloud.com]: FAILED! => {"failed": true, "msg": "last_checked_host: qe-wmeng310nfs-master-etcd-nfs-1.0530-7vd.qe.rhcloud.com, last_checked_var: openshift_hosted_registry_storage_kind;nfs is an unsupported type for openshift_hosted_registry_storage_kind. openshift_enable_unsupported_configurations=True mustbe specified to continue with this configuration."}

should give the message for upgrade, too.

Version-Release number of the following components:
openshift-ansible-3.10.0-0.54.0.git.0.537c485.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. upgrade OCP v3.9 to v3.10 with 
openshift_hosted_registry_storage_kind=nfs


Actual results:
Upgrade succeeded without message about 
nfs is an unsupported type for openshift_hosted_registry_storage_kind

Expected results:
Give out this info

Comment 1 Weihua Meng 2018-05-30 11:31:59 UTC
Sorry, old version playbook used when met this issue.
It should be fixed with latest 3.10 build.

Comment 2 Scott Dodson 2018-05-30 13:44:51 UTC
ON_QA for retesting w/ latest playbook. Feel free to CLOSED NOTABUG if confirmed not to be a problem.

Comment 3 Weihua Meng 2018-05-31 02:29:55 UTC
Fixed.
openshift-ansible-3.10.0-0.54.0

This issue does exist in openshift-ansible-3.10.0-0.50.0

Comment 5 errata-xmlrpc 2018-07-30 19:16:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.