Bug 1584228 - multipath daemon is hung in 'D' state with the LSI3408/3508 RAID controller
Summary: multipath daemon is hung in 'D' state with the LSI3408/3508 RAID controller
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
Steven J. Levine
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-30 14:06 UTC by Dariusz Wojewódzki
Modified: 2018-10-30 11:28 UTC (History)
8 users (show)

(edit)
The `multipathd readsector0` checker now returns the correct result

Previously, in some cases the `multipathd` daemon was incorrectly calculating the I/O size to use with the `readsector0` checker, causing it to do a 0 size read. This could cause the `multipathd readsector0` checker to return the wrong result. It is also possible that some SCSI devices do not treat a 0 size read command as valid.  With this fix, `multipathd` now uses the correct size for the `readsector0` checker.
Clone Of:
(edit)
Last Closed: 2018-10-30 11:27:28 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3236 None None None 2018-10-30 11:28 UTC

Comment 5 Ben Marzinski 2018-06-22 17:08:36 UTC
Multipathd will now request the correct number of blocks for the readsector0 checker in all cases.  I don't know if that's the root cause of this issue, but it should make the checker issue the correct command.  If the controller is still not honoring it, it is more likely a controller issue.

Comment 20 errata-xmlrpc 2018-10-30 11:27:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3236


Note You need to log in before you can comment on or make changes to this bug.