Bug 158443 - celestia - FC4 x86_64 rebuild failed
celestia - FC4 x86_64 rebuild failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: celestia (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE4Target-x86_64
  Show dependency treegraph
 
Reported: 2005-05-22 08:30 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-11 20:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix compile on 64-bit archs (3.29 KB, patch)
2005-11-05 05:45 EST, Thorsten Leemhuis
no flags Details | Diff

  None (edit)
Description Thorsten Leemhuis 2005-05-22 08:30:47 EDT
This package failed to rebuild on x86_64 for FC4 Development around 2005-04-11
after an automated release bump. No build logs available afaics.
Comment 2 Maurizio Paolini 2005-10-25 10:00:10 EDT
the package rebuilds fine on an ia64 architecture if a patch is  
applied. Note that the problem actually refers to the FC4 version,  
not to the DEVEL version.  You can find more information, the patch 
and a working spec file in http://dmf.unicatt.it/~pasqui/celestia/  
Comment 3 Thorsten Leemhuis 2005-11-05 05:45:08 EST
Created attachment 120754 [details]
fix compile on 64-bit archs

This patch agains current CVS fixes build on 64bit archs. Not the best solution
afaics, but works for me.

Steve, is it okay if I commit this to FC-4 and devel and request build?
Comment 4 Steven Pritchard 2005-11-08 10:45:01 EST
I'll take care of it.  I have a few other issues that I'd like to try to address
before rebuilding.
Comment 5 Steven Pritchard 2006-02-11 20:14:46 EST
The current version of celestia is 1.4.0 (or a post-1.4.0 CVS snapshot in the
devel branch).  It builds fine on x86_64.  I think I can safely close this bug,
but please let me know if I'm missing something.

Note You need to log in before you can comment on or make changes to this bug.