Bug 1584636 - abrt-cli list failed due to cannot connect system dbus: Error calling StartServiceByName
Summary: abrt-cli list failed due to cannot connect system dbus: Error calling StartSe...
Keywords:
Status: CLOSED DUPLICATE of bug 1583080
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: abrt
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-31 10:57 UTC by xhe@redhat.com
Modified: 2018-07-03 12:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-03 12:04:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description xhe@redhat.com 2018-05-31 10:57:25 UTC
Description of problem:
abrt-cli list failed due to can not connect dbus

Version-Release number of selected component (if applicable):
abrt-2.1.11-50.el7.x86_64.rpm 
RHEL-7.6-20180529.n.0 Server x86_64 

How reproducible:
often

Steps to Reproduce:
1. execute "abrt-cli list" on RHEL-7.6-20180529.n.0
Or clone the beaker job https://beaker.engineering.redhat.com/recipes/5220849#task72985561

Actual results:
# abrt-cli list
Can't connect to system DBus: Error calling StartServiceByName for org.freedesktop.problems: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process org.freedesktop.problems received signal 9

Expected results:
abrt-cli works

Additional info:

Comment 2 Jakub Krysl 2018-06-28 09:08:09 UTC
RHEL-7.5:
# uname -r
3.10.0-862.el7.x86_64
# abrt-cli list
The Autoreporting feature is disabled. Please consider enabling it by issuing
'abrt-auto-reporting enabled' as a user with root privileges

RHEL-7.6:
# uname -r
3.10.0-915.el7.x86_64
# abrt-cli list
Can't connect to system DBus: Error calling StartServiceByName for org.freedesktop.problems: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process org.freedesktop.problems received signal 9

So it is a regression, setting accordingly. 
But I tried updating abrt and abrt-cli on RHEL-7.5 to the ones on RHEL-7.6 and the result is the same (work on 7.5, fails on 7.6), so probably not an abrt regression. Not sure what cased it though, so leaving it to abrt. Please investigate and change component if needed.

versions tested on RHEL 7.5 / 7.6:
abrt-2.1.11-51.el7
abrt-cli-2.1.11-51.el7

Note: 'abrt-auto-reporting enabled' results in the same, just without the warning on 7.5.

Comment 4 Martin Hoyer 2018-07-02 12:09:02 UTC
Could be a dup of bz#1583080

Comment 5 Martin Kutlak 2018-07-03 12:04:34 UTC
I can confirm that this issue should be fixed with selinux-policy-3.13.1-205.el7.

*** This bug has been marked as a duplicate of bug 1583080 ***


Note You need to log in before you can comment on or make changes to this bug.