Bug 1584657 - libreoffice-langpack-de package does not pulled in after installation with de_DE locale
Summary: libreoffice-langpack-de package does not pulled in after installation with de...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 28
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-31 11:55 UTC by Satyabrata Maitra
Modified: 2019-04-09 06:58 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-09 06:58:51 UTC


Attachments (Terms of Use)

Description Satyabrata Maitra 2018-05-31 11:55:41 UTC
Description of problem:
After Installing Fedora-28 Gold(GA) Workstation with default de_DE(German) locale, with libreoffice installed(clicked during anaconda package selection), but libreoffice-langpack-de package is found missing.

Version-Release number of selected component (if applicable):

libreoffice-langpack-de-6.0.3.2-1.fc28 (found missing by default installation)
glibc-langpack-de-2.27-8.fc28 (found missing by default installation)
glibc-all-langpacks-2.27-8.fc28 (found installed)

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 28 Gold(GA) Workstation with German Language
2. Click on Libreoffice (Office Suits) in Package Selection section in Anaconda 
   installer
3. Post installation, check the following :
   rpm -qa | grep libreoffice-langpack-de
   rpm -qa | grep glibc-langpack-de
   rpm -qa | grep glibc-all-langpacks
4. Open libreoffice writer/calc/ooimpress

Actual results:
First 2 rpm commands are returning nothing (with default installation)
libreoffice is launching in English locale

Expected results:
Default installation should pull respective language langpack by default
First 2 rpm query should return respective output :
libreoffice-langpack-de-6.0.3.2-1.fc28
glibc-langpack-de-2.27-8.fc28

Additional info:

Comment 1 Satyabrata Maitra 2018-05-31 11:57:38 UTC
There is a relevant bug on this with upgrade : https://bugzilla.redhat.com/show_bug.cgi?id=1574222

Please feel free to close this bug (bug #1584657) if it looks a duplicate of bug #1574222.

Comment 2 Caolan McNamara 2018-05-31 12:34:25 UTC
whereever the bug is, its definitely not a bug in libreoffice itself

Comment 3 Satyabrata Maitra 2019-04-09 06:58:51 UTC
Retested this bug on Fedora-30 live installation with French(fr_FR) locale and libreoffice-langpack-fr doesn't get installed after anaconda default installation. It is probably due to the huge size of all libreoffice-langpack-* as a bundle, which may not fit for Live instance.

Packages got installed with default installation(fr_FR) : 
glibc-all-langpacks-2.29-8.fc30.x86_64
libreoffice-langpack-en-6.2.1.2-6.fc30.x86_64
langpacks-en-1.0-16.fc30.noarch
glibc-langpack-en-2.29-8.fc30.x86_64

So, closing this bug as Wontfix as of now. Please feel free to reopen it if required.


Note You need to log in before you can comment on or make changes to this bug.