Bug 158468 - x86_64 tg3 fails to get IP address via DHCP from boot.iso
x86_64 tg3 fails to get IP address via DHCP from boot.iso
Status: CLOSED DUPLICATE of bug 159078
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-05-22 12:39 EDT by Sean Bruno
Modified: 2015-01-04 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-02 01:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmidecode on ASUS K8N-DL, dual 246, 6gb ram (17.94 KB, text/plain)
2005-05-24 12:17 EDT, Sean Bruno
no flags Details
Output of lspci -vv on ASUS K8N-DL, dual 246, 6gb ram (18.94 KB, text/plain)
2005-05-24 12:36 EDT, Sean Bruno
no flags Details
Output of dmesg after a bootup (19.99 KB, text/plain)
2005-05-28 20:05 EDT, Sean Bruno
no flags Details

  None (edit)
Description Sean Bruno 2005-05-22 12:39:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
In an attempt to install the x86_64 version of FC4T3, I tried to net install from rawhide.  I never got past the part of the installer that attempts to determine the IP address.  It looks like a kernel oops when attempting to insert the tg3 adapter to handle the Broadcom NetXtreme on board ethernet card in my box.

If you folks want me to capture this information from the console, I would be more than willing to hook up the serial console.  I just am not sure how to do this between two machines, so I would need a little "HOW-TO" besides the one that is in the kernel-docs as it is WAY out of date.

Version-Release number of selected component (if applicable):
FC4T3 DVD ISO

How reproducible:
Always

Steps to Reproduce:
1.  Attempt to install FC4T3 via any network install method(linux askmethod)
2.
3.
  

Actual Results:  Install aborts with what looks like a kernel oops.

Expected Results:  Install should have continued normally.

Additional info:

I am completely stymied on my attempts to install FC4 on my dual opteron machine at this point.  Any help would be appreciated.
Comment 1 Warren Togami 2005-05-22 17:11:24 EDT
My Tyan motherboard with dual opteron worked with both HTTP and FTP installs
over tg3 for the past few days of rawhide.  I haven't tested FC4test3.

Has your dual opteron been net installable with any earlier FC?
Comment 2 Sean Bruno 2005-05-22 20:04:48 EDT
Nope.  Let me try the i386 version of FC4.
Comment 3 Sean Bruno 2005-05-22 20:08:41 EDT
Looks like it will net-install from the i386 DVD-ROM.  Must be x86_64 specific?
Comment 4 Warren Togami 2005-05-22 21:30:56 EDT
Nope, my tests of both i386 and x86_64 were working fine.  Did both from
yesterday's rawhide.

Again I did NOT test FC4test3.  Only rawhide which is a bit newer than FC4test3.
Comment 5 Sean Bruno 2005-05-22 21:42:43 EDT
Well, how do I install from rawhide?  I would love to be able to test it out,
but I don't know how to use an updated installer(if such a thing exists!).  
Comment 6 Warren Togami 2005-05-22 21:47:44 EDT
Download boot.iso from any Fedora Core development mirror, then start a HTTP or
FTP install using that URL.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/images/boot.iso
Here is the i386 version.

Site download.fedora.redhat.com
/pub/fedora/linux/core/development/i386/
And this is what the installer asks for.  You may want to choose a closer mirror
that is faster for you than this though.
Comment 7 Sean Bruno 2005-05-22 21:53:34 EDT
There is no problem installing the i386 version of FC4 T3(see Comment #3).  The
version that is exploding is the x86_64. 

By exploding, I mean that the Broadcom Network adapter driver(tg3) is crashing
the install(kernel oops?) when I get to the DHCP section of the install.  

If I grab the x86_64 version of boot.iso, will it be a different version than
the one used in the FC4T3 DVD?
Comment 8 Warren Togami 2005-05-22 22:05:59 EDT
Yes, but use the x86_64 base directory rather than i386 for development install.

At this point testing of FC4test3 install wont help us, because the kernel has
changed much since then.  Please test the development kernel, then after you
have installed test the even newer kernels from here:

http://people.redhat.com/davej/kernels/Fedora/
Comment 9 Sean Bruno 2005-05-23 13:26:57 EDT
The "oops" I was seeing doesn't appear to be relevant to the tg3 driver.  It
actually looks like it is coming out of the ohci1394(firewire) driver.  There
are no issues booting the machine on the x86_64 boot.iso image from development,
the issue appears when I set the machine to DHCP it's IP address and the
folowing error appears on screen:

Disabling IRQ #209

If I look at the console log from the installer, the following Call Trace appears:

<3> irq 209:  nobody cared!
<4>
<4> Call Trace:     <IRQ>  <ffffffff80171325> {__report_bad_irq+53} 
<ffffffff801713fc> {node_interrupt+92}
<4>   <ffffffff801705bc> {__do_IRQ+652}  <ffffffff8013c48e> {prifile_tick+78}
<4>   <ffffffff801120b8> {do_IRQ+72} <ffffffff8010f6c3> {ret_from_intr+0}
<4>   <EOI> <ffffffff8010d230> {default_idle+0} <ffffffff8010d252> {default_idle+34}
<4>   <ffffffff8010d291> {cpu_idle+49} <ffffffff805847e5> {start_kernel+469}
<4>   <ffffffff805841f4> {_sinittext+500}
<3>   handlers:
<3>   [<ffffffff8818c5b0>] (ohci_irq_handler+0x0/0xd10 [ohci1394])
<0>   Disabling IRQ #209

This only happens once with the x86_64 iso and the attempt to DHCP fails.  I
tried to DHCP a second and third time and no IP address was assigned.

I assigned a static IP address and the reverse name lookup fails.  In addition,
it appears to not be able to get out of the box to the network.

I will try the i386 boot.iso and report back.
Comment 10 Sean Bruno 2005-05-23 13:52:23 EDT
The i386 boot.iso appears to be able to boot properly and configure the
Broadcom(tg3) ethernet adapter via DHCP.  

I tried to switch the install directory to the "x86_64" tree instead of the
"i386" tree from the links in Comment #6.  Comment #8 indicates that this should
be possible, but the installer pops up an error window that says the
architecture of the tree doesn't match the architecture of the boot media.  Is
there a way around this?
Comment 11 Warren Togami 2005-05-23 15:57:31 EDT
Comment #8 did not indicate that.

Are you able to do the development x86_64 install if you add "nofirewire" to the
boot?  "linux nofirewire" from the boot CD.
Comment 12 Sean Bruno 2005-05-23 17:59:39 EDT
The nofirewire argument makes the error that was reported in Comment #9 go away,
but the machine is still failing to DHCP any IP address from the x86_64 boot.iso
image.

It almost looks like the tg3 module isn't able to initialize the ethernet card
correctly.  Can I post any information that would assist in resolution?
Comment 13 Warren Togami 2005-05-23 18:04:17 EDT
My x86_64 tg3 tests have never shown any trouble since FC2, so you're on your
own here.  My only suggestion is to post for help upstream and search
bugzilla.kernel.org for anything similar.
Comment 14 Sean Bruno 2005-05-23 18:06:30 EDT
Should we break these two issues into seperate bugs?

Comment 15 Warren Togami 2005-05-23 18:13:54 EDT
Bug #158424 mentions firewire, is that the issue you have?  I didn't read
details deeply.
Comment 16 Sean Bruno 2005-05-24 12:07:52 EDT
I don't think bug #158424 is the same error I am seeing on the installer.  The
error is different. See Comment #9.
Comment 17 Sean Bruno 2005-05-24 12:17:32 EDT
Created attachment 114778 [details]
Output of dmidecode on ASUS K8N-DL, dual 246, 6gb ram

Does the Broadcom adapter seem to be too new?  In other words is there
something about the Broadcom on my Mobo that is different than other cards?
Comment 18 Sean Bruno 2005-05-24 12:29:58 EDT
Today's boot.iso
(http://download.fedora.redhat.com/pub/fedora/linux/core/development/x86_64/images/boot.iso)

still fails to aquire an IP address from DHCP.  It also still throws the error
from Comment #9 if I have the firewire controller enabled.

Comment 19 Sean Bruno 2005-05-24 12:36:10 EDT
Created attachment 114782 [details]
Output of lspci -vv on ASUS K8N-DL, dual 246, 6gb ram

I did an lspci -vv as root after I realized that dmidecode won't show the
Broadcom Ethernet controller details.
Comment 20 Sean Bruno 2005-05-24 13:02:15 EDT
I disabled the on-board Broadcom adapter and inserted an Intel 10/100 pro PCI
card.  I am able to DHCP now and the firewire adapter does not "crash" or throw
the error shown in Comment #9.
Comment 21 Sean Bruno 2005-05-25 11:33:34 EDT
Is there anyway to have the tg3 module log something when it starts during the
installer?  I would like to see if I can get this working as it appears to work
just fine with the i386 version of the module and installer.
Comment 22 Sean Bruno 2005-05-28 14:19:55 EDT
The on-board Broadcom seems to fail to function from the x86_64 boot.iso every
time.  I still see the error in Comment #9 come up whenever the tg3 module is
used by the boot.iso.
Comment 23 Sean Bruno 2005-05-28 15:08:30 EDT
I think I failed to mention that this on-board Broadcom appears to be on the
PCI-Express bus, not the standard PCI bus.
Comment 24 Sean Bruno 2005-05-28 20:05:36 EDT
Created attachment 114947 [details]
Output of dmesg after a bootup

I booted the rescue iso in order to get some better information.  I have
attached the output of dmesg to this ticket.
Comment 25 Sean Bruno 2005-07-02 01:34:58 EDT
I am marking this as a duplicate of Bug# 159078.  I have determined that the
root cause of this ticket will be resolved with that ticket.

*** This bug has been marked as a duplicate of 159078 ***

Note You need to log in before you can comment on or make changes to this bug.