Bug 1584708
| Summary: | s3 deployment fails while deploying OCP + CNS | |||
|---|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Rachael <rgeorge> | |
| Component: | Installer | Assignee: | Saravanakumar <sarumuga> | |
| Status: | CLOSED ERRATA | QA Contact: | Qin Ping <piqin> | |
| Severity: | unspecified | Docs Contact: | ||
| Priority: | unspecified | |||
| Version: | 3.10.0 | CC: | aos-bugs, gpei, hchiramm, jialiu, jokerman, mmccomas, sarumuga | |
| Target Milestone: | --- | Keywords: | Triaged | |
| Target Release: | 3.10.z | |||
| Hardware: | Unspecified | |||
| OS: | Unspecified | |||
| Whiteboard: | ||||
| Fixed In Version: | openshift-ansible-3.10.51-1 | Doc Type: | No Doc Update | |
| Doc Text: | Story Points: | --- | ||
| Clone Of: | ||||
| : | 1585912 (view as bug list) | Environment: | ||
| Last Closed: | 2019-07-24 13:47:18 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | ||||
| Bug Blocks: | 1585912 | |||
There's been some discussion as to whether or not deploying gluster-s3 using the Advanced Installer is the right way to go. While it was initially implemented this way, the recent work Saravana has done with the Service Catalog seems to be a more logical way to provide gluster-s3. PM was involved in these discussions. At the very least, I don't think this will finalize in 3.10. For now I'm moving this out to 3.10.z. We may end up scrapping it altogether. The corresponding change required is merged in upstream: https://github.com/openshift/openshift-ansible/pull/8647 Fixed in openshift-ansible-3.10.51-1 Verified with: ansible-2.4.2.0-2 openshift-ansible-3.10.149 Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2019:1755 |
Description of problem: While deploying OCP+CNS using the ansible playbook, the deployment fails for s3 at the task "openshift_storage_glusterfs : Generate GlusterFS StorageClass for S3 file" with the following error: fatal: [dhcp46-241.lab.eng.blr.redhat.com]: FAILED! => {"changed": false, "failed": true, "msg": "Could not find or access 'v3.10/gluster-s3-storageclass.yml.j2'\nSearched in:\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/templates/v3.10/gluster-s3-storageclass.yml.j2\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/v3.10/gluster-s3-storageclass.yml.j2\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/tasks/templates/v3.10/gluster-s3-storageclass.yml.j2\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/tasks/v3.10/gluster-s3-storageclass.yml.j2\n\t/usr/share/ansible/openshift-ansible/playbooks/common/private/../../openshift-glusterfs/private/templates/v3.10/gluster-s3-storageclass.yml.j2\n\t/usr/share/ansible/openshift-ansible/playbooks/common/private/../../openshift-glusterfs/private/v3.10/gluster-s3-storageclass.yml.j2"} However OCP, Gluster, gluster-block got configured successfully. Version-Release number of the following components: rpm -q openshift-ansible openshift-ansible-3.10.0-0.54.0.git.0.537c485.el7.noarch rpm -q ansible ansible-2.4.4.0-1.el7ae.noarch ansible --version ansible 2.4.4.0 config file = /etc/ansible/ansible.cfg configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules'] ansible python module location = /usr/lib/python2.7/site-packages/ansible executable location = /usr/bin/ansible python version = 2.7.5 (default, Feb 20 2018, 09:19:12) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)] How reproducible:1/1 Steps to Reproduce: 1. Deploy OCP + CNS via ansible playbook 2. Wait for the configuration to complete Actual results: Could not find or access 'v3.10/gluster-s3-storageclass.yml.j2' Searched in: /usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/templates/v3.10/gluster-s3-storageclass.yml.j2 /usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/v3.10/gluster-s3-storageclass.yml.j2 /usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/tasks/templates/v3.10/gluster-s3-storageclass.yml.j2 /usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/tasks/v3.10/gluster-s3-storageclass.yml.j2 /usr/share/ansible/openshift-ansible/playbooks/common/private/../../openshift-glusterfs/private/templates/v3.10/gluster-s3-storageclass.yml.j2 /usr/share/ansible/openshift-ansible/playbooks/common/private/../../openshift-glusterfs/private/v3.10/gluster-s3-storageclass.yml.j2 Expected results: s3 deployment should be successful