Bug 158475 - Nvidia CK804 USB Controller non-functional
Nvidia CK804 USB Controller non-functional
Status: CLOSED DUPLICATE of bug 159078
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-22 13:54 EDT by Sean Bruno
Modified: 2015-01-04 17:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-02 01:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of dmidecode on ASUS K8N-DL, dual 246, 6gb ram (17.94 KB, application/octet-stream)
2005-05-24 11:44 EDT, Sean Bruno
no flags Details
Output of lspci -vv on ASUS K8N-DL, dual 246, 6gb ram (18.94 KB, text/plain)
2005-05-24 12:38 EDT, Sean Bruno
no flags Details

  None (edit)
Description Sean Bruno 2005-05-22 13:54:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I am running the i386 version of FC4T3 as the x86_64 version doesn't install on my ASUS K8N-DL at all.  

I deactivated the USB controller on the CK804 as it was locking the install and wouldn't allow me to get any version of FC4T3(i386 or x86_64) on my box.

After a full update to rawhide, I re-activated the CK804 and plugged in a mouse and a USB thumbdrive.  Neither device appeared on the USB bus(lsusb) and there was no activity in /var/log/messages.

Version-Release number of selected component (if applicable):
FC4T3

How reproducible:
Always

Steps to Reproduce:
1.  Install FC4T3 on a box with a CK804 chipset(you may have to turn off USB to get it to install at all).
2.  Reactivate the USB controller after the install is complete.
3.  Connect any USB device to your computer.
  

Actual Results:  No access to any USB device was possible and a "lsusb" showed nothing connected to the BUS.

Expected Results:  I should have seen Hardware info about the devices on the USB bus from a "lsusb" and I should have had access to the USB mouse and the USB thumdrive.  Both of these devices work just fine under FC4T3 on my Latitude D800 laptop from Dell and my Optiplex GC270 from Dell.

Additional info:

I can give someone access to this machine across the network if they are so inclined.  It is a fresh install, so there is no danger of comprimising my data.
Comment 1 Pete Zaitcev 2005-05-22 21:20:22 EDT
"Reactivated" is not specific enough. What did you do, exactly?
Did kudzu detect it after this so-called "reactivation"? What about lspci?
Comment 2 Sean Bruno 2005-05-22 21:40:10 EDT
In order to get the i386 version to install at all, I disabled the USB
controller from the BIOS altogether.  I "reactivated" it from the BIOS after a
full updated to rawhide.

Output of lspci with the USB controller disabled in BIOS:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:08.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
01:09.0 RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid]
Serial ATA Controller (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 11)
04:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200
TurboCache] (rev a1)
Comment 3 Dave Jones 2005-05-23 16:09:00 EDT
Is this still occuring with the latest updates ?
Comment 4 Sean Bruno 2005-05-24 11:31:37 EDT
This is still happening with kernel 2.6.11-1.1340_FC4.  Here is the output of
lspci with the USB controller enabled:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:08.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
01:09.0 RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid]
Serial ATA Controller (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 11)
04:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200
TurboCache] (rev a1)


No activity is noted when I connect any USB device to the BUS.  I have tried a
known good Mouse and USB mem stick.
Comment 5 Sean Bruno 2005-05-24 11:44:17 EDT
Created attachment 114776 [details]
Output of dmidecode on ASUS K8N-DL, dual 246, 6gb ram

Output of dmidecode on ASUS K8N-DL, dual 246, 6gb ram

I was running the uni-processor i386 kernel as I cannot run an SMP kernel or
the x86_64 install
Comment 6 Sean Bruno 2005-05-24 12:38:28 EDT
Created attachment 114783 [details]
Output of lspci -vv on ASUS K8N-DL, dual 246, 6gb ram

Thought I would put the output of lspci here.
Comment 7 Sean Bruno 2005-05-28 14:26:12 EDT
I am changing this ticket to x86_64.  It still is broken in i386 kernels, but I
am testing x86_64 more than i386 at this time.
Comment 8 Sean Bruno 2005-07-02 01:36:25 EDT
I am marking this ticket as a duplicate of Bug# 159078 as new information was
forwarded to me that indicates resolution of that bug will resolve this issue as
well.

*** This bug has been marked as a duplicate of 159078 ***

Note You need to log in before you can comment on or make changes to this bug.