Bug 158499 - findfs fails to find label after install
findfs fails to find label after install
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
: 158500 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-22 22:30 EDT by Adam Hitchcock
Modified: 2008-02-16 10:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-16 10:47:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of findfs (9.08 KB, text/plain)
2005-05-27 10:55 EDT, Paul Nasrat
no flags Details

  None (edit)
Description Adam Hitchcock 2005-05-22 22:30:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412

Description of problem:
Installation completes correctly, however, upon attempting to mount the / partition it gives the error

>Checking filesystems  [ FAIL ]
>fsck.ext3: Unable to resolve 'LABEL=/'

in /etc/fstab line 1
LABEL=/   /   ext3 defaults 1 1
should be:
/dev/hdaX   /   ext3 defaults 1 1
(where X is where / is located)

to fix from the recovery prompt you must remount the / partition in read/write mode, edit /etc/fstab, 
remount / in read only, reboot.
to do this do thus:
1. enter password
2. $> mount -o remount,rw /
3. $> vi /etc/fstab
4. change LABEL=/ to just have it pointing to /dev/hdaX 
5. $> mount -o remount,ro /
6. $> Ctrl-D

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fedora core 4 test 3
2. let machine reboot
3. see error
  

Actual Results:  Checking filesystems  [ FAIL ]
>fsck.ext3: Unable to resolve 'LABEL=/'

in /etc/fstab line 1
LABEL=/   /   ext3 defaults 1 1

Expected Results:  The machine should finish the booting normally.

in /etc/fstab line 1
/dev/hdaX   /   ext3 defaults 1 1
(where X is where / is located)

Additional info:

I have only tried this on my iBook 500 dual usb thus far, I will attempt to reproduce it on on other PPC 
machines.
Comment 1 Paul Nasrat 2005-05-23 09:57:06 EDT
*** Bug 158500 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2005-05-23 11:36:12 EDT
What does e2label /dev/hdaX show?
Comment 3 Jeremy Katz 2005-05-23 13:51:24 EDT
Note:  I just tried this on my 400 mhz imac and it works fine.  Used partitions
instead of LVM and thus LABEL=/ is being mounted as / and fsck was fine.
Comment 5 Paul Nasrat 2005-05-27 10:55:43 EDT
Created attachment 114913 [details]
Strace of findfs

I've just hit this here:

e2label /dev/hda3 
/boot

findfs LABEL=/boot fails
Unable to resolve 'LABEL=/boot'
Comment 6 Paul Nasrat 2005-05-27 11:17:49 EDT
/etc/blkid.tab is empty.
Comment 7 Paul Nasrat 2005-05-27 11:29:35 EDT
In addition blkid -c /tmp/foo generates an empty cache file

Comment 8 Thomas Woerner 2005-05-27 12:37:40 EDT
Found the problem: It was a strange date:
# date
Sat Jan  9 01:34:48 EST 1904
Comment 9 Richard Hughes 2006-01-25 17:10:34 EST
"unable to resolve LABEL=/boot"

My date of /etc/blkid.tab is 01/01/1904.

I edited /etc/fstab by hand to use /dev/hda3 so I could get fc5t2 to finish
installing (and rawhide has the same issue btw) but this is obviously a bug for FC5.

Powerbook has no cmos battery anymore, and relies on ntp for the time and date,
which probably explains the dodgey date.
Comment 10 Christian Iseli 2007-01-22 06:41:39 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 11 Matthew Miller 2007-04-06 11:06:56 EDT
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.
Comment 12 Red Hat Bugzilla 2007-08-21 01:20:17 EDT
User pnasrat@redhat.com's account has been closed
Comment 13 petrosyan 2008-02-16 10:47:15 EST
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.