Bug 1585007 - Variables undefined during installation
Summary: Variables undefined during installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-01 06:40 UTC by Gan Huang
Modified: 2018-07-30 19:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:17:31 UTC

Description Gan Huang 2018-06-01 06:40:38 UTC
Description of problem:

Two issues observed in commit 8e02233b0ce5248179223c9419ad8759d1c40630

TASK [openshift_docker_gc : Create dockergc DaemonSet] *************************
Friday 01 June 2018  02:24:22 -0400 (0:00:00.662)       0:15:39.817 *********** 
fatal: [qe-ghuang-10-master-etcd-nfs-1.0601-tp4.qe.rhcloud.com]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: {{ l_os_registry_url | regex_replace(l_openshift_logging_search | regex_escape, l_os_dockergc_replace) }}: 'l_openshift_logging_search' is undefined"}
	to retry, use: --limit @/home/slave1/workspace/Launch-Environment-Flexy/private-openshift-ansible/playbooks/deploy_cluster.retry


TASK [openshift_descheduler : copy the cronjob file for descheduler] ***********
Thursday 31 May 2018  21:43:35 -0400 (0:00:00.870)       0:11:54.021 ********** 
fatal: [host-8-248-37.host.centralci.eng.rdu2.redhat.com]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: {{ l_os_descheduler_image | regex_replace(l_os_descheduler_image_search | regex_escape, 'descheduler') }}: {{ l_os_non_standard_reg_url | regex_replace('${version}' | regex_escape, l_os_logging_proxy_image_version) }}: 'l_os_logging_proxy_image_version' is undefined"}
	to retry, use: --limit @/home/slave3/workspace/Launch Environment Flexy/private-openshift-ansible/playbooks/deploy_cluster.retry

 

Version-Release number of the following components:
openshift-ansible-3.10.0-0.56.0.git.0.b921fb9.el7.noarch.rpm

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Scott Dodson 2018-06-01 19:47:16 UTC
https://github.com/openshift/openshift-ansible/pull/8592 submitted by Gan

Comment 3 Gan Huang 2018-06-06 03:09:15 UTC
Verified in 3.10.0-0.58.0

Comment 5 errata-xmlrpc 2018-07-30 19:16:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.