Bug 1585114 - Unknown resource for replicationcontrollerdummies/extensions/v1beta1
Summary: Unknown resource for replicationcontrollerdummies/extensions/v1beta1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.10.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-01 10:10 UTC by shahan
Modified: 2018-07-23 13:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-11 13:14:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
error (27.50 KB, image/png)
2018-06-01 10:10 UTC, shahan
no flags Details

Description shahan 2018-06-01 10:10:57 UTC
Created attachment 1446631 [details]
error

Description of problem:
  Unknown resource for replicationcontrollerdummies/extensions/v1beta1

Version-Release number of selected component (if applicable):
OpenShift Master: v3.10.0-0.56.0 
Kubernetes Master: v1.10.0+b81c8f8 
OpenShift Web Console: v3.10.0-0.56.0

How reproducible:
Always

Steps to Reproduce:
1. Login web console with clusteradmin user
2. Goto other Resouces,click  replicationcontrollerdummies
3.

Actual results:
Will occur error:  Unknown resource for replicationcontrollerdummies/extensions/v1beta1

Expected results:
should has no error

Additional info:

Comment 3 shahan 2018-06-07 03:04:08 UTC
[hasha@mypc origin-web-console]$ git log --pretty="%h %cd - %s"   e944f82 |   grep   '3010'
ff6bcd86 Fri Jun 1 10:20:13 2018 -0700 - Merge pull request #3010 from openshift/rc-dummy

Dose replicationcontrollerdummies be moved out from other resource drop-down list? I cannot find it with cluster-admin user.
Not sure if this is our expected result?

Comment 4 shahan 2018-06-07 03:08:39 UTC
sorry, forgot to give server version:
OpenShift Master: v3.10.0-0.63.0 
Kubernetes Master: v1.10.0+b81c8f8 
OpenShift Web Console: v3.10.0-0.63.0

Comment 5 shahan 2018-06-11 01:53:04 UTC
from PR https://github.com/openshift/origin-web-common/pull/335, it should be fixed.

Comment 6 Samuel Padgett 2018-06-11 13:14:29 UTC
> Dose replicationcontrollerdummies be moved out from other resource drop-down list?

Yes, it was removed from the list on purpose because it's not a real resource.


Note You need to log in before you can comment on or make changes to this bug.