Bug 1585316 - [RFE] VLAN tenant networks should not depend on Overlay tunnels for SNAT traffic
Summary: [RFE] VLAN tenant networks should not depend on Overlay tunnels for SNAT traffic
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: lpeer
QA Contact: Itzik Brown
URL:
Whiteboard:
: 1585449 (view as bug list)
Depends On:
Blocks: 1528948
TreeView+ depends on / blocked
 
Reported: 2018-06-01 20:33 UTC by Sridhar Gaddam
Modified: 2019-03-06 16:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 16:15:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sridhar Gaddam 2018-06-01 20:33:05 UTC
Description of problem:
Currently, SNAT traffic from the Compute Node to the NAPT Switch always goes through overlay tunnels by design, even when the tenant networking is VLAN.
This is a design oversight on Netvirt. Ideally the SNAT traffic should go via the tenant network for reaching the NAPT Switch from where its sent to the external network.

           +---------------------------+
           | 8.8.8.8 (External Server) |
           +-----------+---------------+
                       |
  +------+-------------+----------------------+
         |                External Network (FLAT/VLAN)
         |
         |   ---+-------------------------------+-------+
         |      |          Tenant VLAN Network  |
         |      |                               |
         |      |                               |
       +-+------+---------+         +-----------+---------+
       |    ComputeNode   |         |     ComputeNode     |
       |      hosting     |         |       hosting       |
       |    NAPT Switch   |         |         VM          |
       +------------------+         +---------------------+

Comment 1 Mike Kolesnik 2018-06-06 10:57:24 UTC
*** Bug 1585449 has been marked as a duplicate of this bug. ***

Comment 2 Franck Baudin 2019-03-06 16:15:13 UTC
As per depreciation notice [1], closing this bug. Please reopen if relevant for RHOSP13, as this is the only version shipping ODL.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/14/html-single/release_notes/index#deprecated_functionality

Comment 3 Franck Baudin 2019-03-06 16:17:21 UTC
As per depreciation notice [1], closing this bug. Please reopen if relevant for RHOSP13, as this is the only version shipping ODL.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/14/html-single/release_notes/index#deprecated_functionality


Note You need to log in before you can comment on or make changes to this bug.