Bug 1585457
| Summary: | [RHOSP10][galera]Unable to bootstrap controller node | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | MD Sufiyan <msufiyan> |
| Component: | galera | Assignee: | Damien Ciabrini <dciabrin> |
| Status: | CLOSED DUPLICATE | QA Contact: | Shai Revivo <srevivo> |
| Severity: | high | Docs Contact: | |
| Priority: | high | ||
| Version: | 10.0 (Newton) | CC: | mbayer, pablo.iranzo, srevivo |
| Target Milestone: | --- | Keywords: | Triaged, ZStream |
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2018-07-23 08:11:21 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Closing this bug now as the original root cause was due to a skipped upgrade from rhel 7.2 to rhel 7.4. *** This bug has been marked as a duplicate of bug 1520574 *** |
1. Description Not able to perform bootstrap for a controller node. 2. Use case We are hitting issue[1] while bootstarping the controller node. [root@hostname ~]# crm_attribute -N <hostname> -l reboot --name galera-bootstrap -v true [root@hostname ~]# crm_attribute -N <hostname> -l reboot --name master-galeracluster -v 100 [root@hostname ~]# crm_resource --force-promote -r galera -V Operation promote for galera:0 (ocf:heartbeat:galera) returned 1 > stdout: non-option ARGV-elements: reboot > stderr: + 09:09:46: 69: . /usr/lib/ocf/lib/heartbeat/mysql-common.sh > stderr: +++ 09:09:46: 6: which mysqld_safe > stderr: ++ 09:09:46: 6: OCF_RESKEY_binary_default=/bin/mysqld_safe > stderr: ++ 09:09:46: 7: '[' /bin/mysqld_safe = '' ']' > stderr: +++ 09:09:46: 12: uname . . . . > stderr: + 09:09:47: __ha_log:195: '[' true = true ']' > stderr: + 09:09:47: __ha_log:197: return 0 > stderr: + 09:09:47: galera_promote:611: clear_last_commit > stderr: + 09:09:47: clear_last_commit:316: /usr/sbin/crm_attribute -N -l reboot --name galera-last-committed -D > stderr: Could not map name=-l to a UUID > stderr: + 09:09:47: galera_promote:612: return 1 Error performing operation: Operation not permitted It seems, crm_attribute is not able declare the hostname and instead picking option "-l" which was ran as part above command. 2. Upstream reference Bugzillas? No Blueprints? No Specs? No 4. RH bugzilla dependencies? No 5. Primary Red Hat contact: a. Name: MD Sufiyan b. Email: msufiyan