Bug 1585605 - [UPDATE] 'ceph-upgrade' command fails with error: "resources.NodeTLSData: Resource CREATE failed", grep command on openstack-neutron-l3-agent returns 2 matches
Summary: [UPDATE] 'ceph-upgrade' command fails with error: "resources.NodeTLSData: Res...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: All
OS: All
urgent
urgent
Target Milestone: ga
: 13.0 (Queens)
Assignee: mathieu bultel
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-04 08:20 UTC by Raviv Bar-Tal
Modified: 2018-06-27 13:58 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-35.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
ceph update command (1.30 KB, text/plain)
2018-06-04 08:42 UTC, Raviv Bar-Tal
no flags Details
ceph udate log (98.26 KB, text/plain)
2018-06-04 08:42 UTC, Raviv Bar-Tal
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 574173 None master: MERGED tripleo-heat-templates: Match only haproxy for docker ps and skipp all *-haproxy occurences (Id63991e862ab10170c8afbde7a... 2018-06-13 12:00:27 UTC
OpenStack gerrit 574624 None stable/queens: NEW tripleo-heat-templates: Match only haproxy for docker ps and skipp all *-haproxy occurences (Id63991e862ab10170c8afbde7a... 2018-06-13 12:00:20 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:58:15 UTC

Description Raviv Bar-Tal 2018-06-04 08:20:40 UTC
Description of problem:
While updating overcloud the command 'ceph-upgrade' (ran after 'openstack overcloud update run --nodes CephStorage' and before 'openstack overcloud update converge') fails with this error:
2018-06-03 11:52:44Z [overcloud-Controller-ezdnestd3o3n-0-jwqqdvrzy5jz]: UPDATE_FAILED  Resource UPDATE failed: resources.NodeTLSData: Resource CREATE failed: Error: resources.ControllerTLSDeployment: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 1
Version-Release number of selected component (if applicable):

For more information about the command and full error log see attached undercloud.tar archive 

How reproducible:


Steps to Reproduce:
1. Install osp13 beta release with ceph 3-6
2. Update to passed_phase2 with ceph 3-8
3.

Actual results:
Update fail

Expected results:
Update pass 

Additional info:

Comment 1 Raviv Bar-Tal 2018-06-04 08:42:15 UTC
Created attachment 1447353 [details]
ceph update command

Comment 2 Raviv Bar-Tal 2018-06-04 08:42:44 UTC
Created attachment 1447354 [details]
ceph udate log

Comment 6 mathieu bultel 2018-06-06 14:58:47 UTC
So according to Raviv, the issue is not reproduced anymore.

(16:51 < rbartal> lbezdick, matbu so this time ceph-upgrade command passed, I don't know why. maybe because the 
                 passed_phase2 build is newer
16:52 < matbu> rbartal: yep i saw that update_complete
16:53 < matbu> rbartal_go_home: thanks for trying to reproduce it
16:54 < matbu> rbartal_go_home: so can you closed it ? or May i
16:54 < matbu> if you are going back to home 
16:54 < rbartal_go_home> matbu, yes, please close it
16:56 < matbu> rbartal_go_home: ack
)

So closing it as NOTABUG

Comment 7 Raviv Bar-Tal 2018-06-11 08:52:09 UTC
This bug was re-opened as we found it reproduce on specific environments (composable) and does not reproduce,
The failure is with grep command on openstack-neutron-l3-agent that returns 2 matches while the script expect 1 match only.

Comment 12 Jon Schlueter 2018-06-13 12:01:19 UTC
Patch not in build

Comment 20 errata-xmlrpc 2018-06-27 13:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.