Bug 1585644 - [v2v] [RFE] RBAC for Migration missing
Summary: [v2v] [RFE] RBAC for Migration missing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Brett Thurber
QA Contact: Kedar Kulkarni
URL:
Whiteboard: v2v
Depends On:
Blocks: 1564236 1595413 1601090
TreeView+ depends on / blocked
 
Reported: 2018-06-04 09:18 UTC by Christian Jung
Modified: 2019-02-11 14:03 UTC (History)
12 users (show)

Fixed In Version: 5.10.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1595413 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:03:54 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
missing RBAC features (135.02 KB, image/png)
2018-06-04 09:18 UTC, Christian Jung
no flags Details

Description Christian Jung 2018-06-04 09:18:22 UTC
Created attachment 1447370 [details]
missing RBAC features

Description of problem:
The RBAC for the new "Migration" feature seems to be a duplicate of the reporting privileges

Version-Release number of selected component (if applicable):
5.10.0.0-pre-nightly.20180413215547_7558ac5

How reproducible:
always

Steps to Reproduce:
1. click on your username and then "Configuration"
2. navigate to "Access control"
3. go to roles and add a new role
4. drill into "Compute" -> "Migration"

Actual results:
there are two sub menus called "reports"

Expected results:
there should be sub menus and items reflecting the feature of the "Migration" UI

Additional info:

Comment 2 Dave Johnson 2018-06-04 09:44:27 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Christian Jung 2018-06-04 09:54:36 UTC
In my opinion this is quite important - otherwise everyone with a CF account and too relaxed privileges might be able to trigger a workload migration. From my field experience I know customers want to be able to have fine grained RBAC for all CF features.

I set prio and sev accordingly.

Comment 8 Brett Thurber 2018-06-22 20:32:57 UTC
https://github.com/ManageIQ/manageiq/pull/17596

Comment 11 Kedar Kulkarni 2018-07-05 19:37:12 UTC
on 5.10.0.2 I could see RBAC option for Migration was present in the Product Features tree. I also confirm that un-checking it will hide the migration option under Compute, and user will no longer be able to navigate to Compute -> Migration.


Note You need to log in before you can comment on or make changes to this bug.