Bug 15857 - Nits that apply to rpm 3.0.5
Nits that apply to rpm 3.0.5
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 13:19 EDT by kestes
Modified: 2007-04-18 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 10:16:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kestes 2000-08-09 13:19:58 EDT
A) Please do not use the release numbers for your own use.

	Version: %{version}
	Release: 9.6x.1

I need to use the release numbers for when I rollout new dependencies
and new spec files.  You really should have called this 

	Version: %{version}-9.6x.1

B) Why not put all my dependency programs into a directory (perhaps
even package) of their own:

	%{__prefix}/lib/rpm/depends

then we can make 

	%{__prefix}/lib/rpm/find-requires

a link to

	%{__prefix}/lib/rpm/depends/find-requires

C) The configure script checks for a different verision of patch then
your Conficts do

	Conflicts: patch < 2.5
	checking old version of patch... patch later then 2.2 found

D) You define two macros which I do not see used anywhere:

	 __share and _noPayloadPrefix 

I assume they are somehow "magic"

E)  I do not like your new dependencies
         rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by
perl-5.00503-11

I would rather see the outername space used to denote the type of
dependency then the inner one can denote the "attribute".

         solib(rpmlib::VersionedDependencies) <= 3.0.3-1 is needed by
perl-5.00503-11
Comment 1 Paul Nasrat 2005-05-18 10:16:19 EDT
This bug is extremely old, as such I'm closing, if you feel any of the issues
should be reopened against rpm 4.4.x in Fedora development please do so.

Note You need to log in before you can comment on or make changes to this bug.