Bug 1585815 - [starter-ca-central-1] during 3.9->3.10 upgrade, unquoted options in /etc/sysconfig/atomic-openshift-master-api cause atomic-openshift-node crash loop
Summary: [starter-ca-central-1] during 3.9->3.10 upgrade, unquoted options in /etc/sys...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.z
Assignee: Michael Gugino
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-04 20:02 UTC by Justin Pierce
Modified: 2019-01-10 09:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: systemd sysconfig env file parsed differently than how master api/controller parses native env file. Consequence: sysconfig env file migrated to master.env file. Lack of quotes around values that contain spaces in env file causes master processes to be misconfigured when values contain spaces. Fix: Created custom parser to ensure items with unescaped or unquoted strings are properly quoted. Result: Migrated env files are properly quoted and master processes are configured properly
Clone Of:
Environment:
Last Closed: 2019-01-10 09:27:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0026 None None None 2019-01-10 09:27:16 UTC

Description Justin Pierce 2018-06-04 20:02:43 UTC
Description of problem:
During 3.9->3.10 upgrade, unquoted OPTIONS in /etc/sysconfig/atomic-openshift-master-api. e.g.
OPTIONS=--loglevel=2 --listen=https://0.0.0.0:443 --master=https://somehost.internal

get migrated into master.env during the control plan upgrade. The line gets placed verbatim into master.env and subsequently sourced by the master. In this case, the lack of quotes makes the source of master.env fail.


Version-Release number of the following components:
v3.10.0-0.54.0

How reproducible:
100%

Steps to Reproduce:
1. In a 3.9 cluster, include unquoted OPTIONS var like example in Description
2. Upgrade to 3.10 control plane
3. Observe crash loop in atomic-openshift-node service

Actual results:
Crash loop during control-plane upgrade.

Expected results:
Several options:
(1) Quote the key value pairs moving into master.env if quotes are missing
(2) source /etc/sysconfig/atomic-openshift-master-* as a test and stop the install if the file cannot be consumed
(3) Require values in the inventory.

Comment 7 errata-xmlrpc 2019-01-10 09:27:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0026


Note You need to log in before you can comment on or make changes to this bug.