Bug 1585824 - Add --allow description to mpathconf man page
Summary: Add --allow description to mpathconf man page
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Lin Li
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-04 20:30 UTC by John Pittman
Modified: 2018-10-30 11:28 UTC (History)
7 users (show)

(edit)
undefined
Clone Of:
(edit)
Last Closed: 2018-10-30 11:27:28 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3236 None None None 2018-10-30 11:28 UTC

Description John Pittman 2018-06-04 20:30:24 UTC
Description of problem:

The --allow option is present in the 'mpathconf --help' menu, but there is no description in the man page.

Version-Release number of selected component (if applicable):

device-mapper-multipath-0.4.9-119.el7.x86_64

Steps to Reproduce:

Run 'man mpathconf' and check for --allow option

Actual results:

No explanation

Expected results:

Explanation of option in the man page, including the expected way to specify more than one wwid to allow (this is what I was looking for in the man page).

Comment 2 Ben Marzinski 2018-06-22 16:21:15 UTC
The man page has been updated to describe --allow as well as --outfile

Comment 4 Lin Li 2018-07-26 17:04:08 UTC
Verified on device-mapper-multipath-0.4.9-121.el7
[root@storageqe-06 ~]# rpm -qa | grep multipath
device-mapper-multipath-libs-0.4.9-121.el7.x86_64
device-mapper-multipath-0.4.9-121.el7.x86_64

Run 'man mpathconf' and check for --allow option
       --allow <device>
              Modifies  the  /etc/multipath/conf  blacklist  to
              blacklist  all wwids and the blacklist_exceptions
              to whitelist <device>. <device>  can  be  in  the
              form  of  MAJOR:MINOR,  a  wwid, or the name of a
              device-mapper device, either a multipath  device,
              or  any  device  on stacked on top of one or more
              multipath devices. This command can be used  mul‐
              tiple  times  to  allow  multiple devices.  NOTE:
              This action will create a configuration file that
              mpathconf  will not be able to revert back to its
              previous state. Because  of  this,  --outfile  is
              required when using --allow.
       --outfile <filename>
              Write the resulting multipath configuration to <filename>
              instead of /etc/multipath.conf.


Test result: The man page has been updated to describe --allow as well as --outfile

Comment 6 errata-xmlrpc 2018-10-30 11:27:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3236


Note You need to log in before you can comment on or make changes to this bug.