Bug 1585940 - the traptoemail script from the net-snmp-perl breaks date in mail header
Summary: the traptoemail script from the net-snmp-perl breaks date in mail header
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: net-snmp
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-05 07:12 UTC by Michal Žejdl
Modified: 2019-08-06 13:08 UTC (History)
2 users (show)

Fixed In Version: net-snmp-5.7.2-39.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:08:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch (582 bytes, patch)
2018-06-05 07:12 UTC, Michal Žejdl
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2239 None None None 2019-08-06 13:08:57 UTC

Description Michal Žejdl 2018-06-05 07:12:56 UTC
Created attachment 1447749 [details]
patch

Description of problem:

https://sourceforge.net/p/net-snmp/bugs/2631/


Version-Release number of selected component (if applicable):

net-snmp-perl-5.7.2-33.el7_5.2.x86_64


How reproducible:

always


Steps to Reproduce:
1. system locale set to non-EN (my is LANG=cs_CZ.UTF-8)
2. traphandle default traptoemail any_email_address (/etc/snmp/snmptrapd.conf)
3. generate some SNMP trap for snmptrapd, see date in the arrived mail


Actual results:

from traptoemail:
Date: Ăšt,  5 ÄŤen 2018 09:11:05 +0200


Expected results:

from MTA:
Date: Sat,  2 Jun 2018 13:07:08 +0200 (CEST)


Additional info:

comment out the line with "Date: " is sufficient, but this workaround doesn't survive package update

Comment 2 Josef Ridky 2018-06-07 10:26:18 UTC
Thank you for taking the time to report this issue to us. We appreciate the feedback and use reports such as this one to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through the regular Red Hat support channels to ensure it receives the proper attention and prioritization to assure a timely resolution. 

For information on how to contact the Red Hat production support team, please visit:
    https://www.redhat.com/support/process/production/#howto


Patch has been delivered to upstream. After upstream accept it, I can apply it in Fedora/RHEL as well.

Comment 7 errata-xmlrpc 2019-08-06 13:08:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2239


Note You need to log in before you can comment on or make changes to this bug.