Bug 1585943 - [UPGRADES] 'Could not find the requested service xinetd' on pre-provisioned servers
Summary: [UPGRADES] 'Could not find the requested service xinetd' on pre-provisioned s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Yurii Prokulevych
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-05 07:15 UTC by Yurii Prokulevych
Modified: 2018-08-22 04:31 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-31.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1775154 None None None 2018-06-05 10:04:57 UTC
OpenStack gerrit 572327 'None' 'MERGED' 'Add sanity checks for xinetd service restart.' 2019-12-06 00:54:02 UTC
OpenStack gerrit 572998 'None' 'MERGED' 'Add sanity checks for xinetd service restart.' 2019-12-06 00:54:02 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:58:15 UTC

Description Yurii Prokulevych 2018-06-05 07:15:40 UTC
Description of problem:
=======================
Upgrade from RHOS-12 to RHOS-13 with pre-provisioned environments fails during Controller upgrade

openstack overcloud upgrade run \
    --ssh-user tripleo-admin \
    --stack overcloud \
    --roles ControllerDeployedServer --playbook all
...
 u'TASK [Restart xinetd service after rsync removal] ******************************',
 u'fatal: [192.168.24.108]: FAILED! => {"changed": false, "msg": "Could not find the requested service xinetd: host"}',
 u'fatal: [192.168.24.107]: FAILED! => {"changed": false, "msg": "Could not find the requested service xinetd: host"}',
 u'fatal: [192.168.24.106]: FAILED! => {"changed": false, "msg": "Could not find the requested service xinetd: host"}',
 u'',
 u'PLAY RECAP *********************************************************************',
 u'192.168.24.106             : ok=293  changed=198  unreachable=0    failed=1   ',
 u'192.168.24.107             : ok=267  changed=173  unreachable=0    failed=1   ',
 u'192.168.24.108             : ok=255  changed=157  unreachable=0    failed=1   '

Seems to be caused by:
https://github.com/openstack/tripleo-heat-templates/blob/stable/queens/docker/services/pacemaker/database/mysql.yaml#L377-L378

Indeed there is no xinetd.service:
  systemctl status xinetd
  Unit xinetd.service could not be found.



Version-Release number of selected component (if applicable):
=============================================================
openstack-tripleo-heat-templates-8.0.2-28.el7ost.noarch

Steps to Reproduce:
===================
1. Deploy RHOS-12 with pre-provisioned servers
2. Upgrade UC to RHOS-13
3. Follow upgrade procedure (repo/image setup/prepare/...)
4. Run upgrade of Controller role

Actual results:
===============
Upgrade fails

Expected results:
=================
Upgrade succeeds

Additional info:
================
Virtual env: 3controllers + 2computes + 3ceph

Comment 1 Yurii Prokulevych 2018-06-05 09:42:46 UTC
After follow up check with Damien found failed task comes from 
https://github.com/openstack/tripleo-heat-templates/blob/stable/queens/docker/services/swift-storage.yaml#L533-L535

To bypass issue added next workaround :

--- /usr/share/openstack-tripleo-heat-templates/docker/services/swift-storage.yaml.orig 2018-06-05 05:38:02.657000000 -0400
+++ /usr/share/openstack-tripleo-heat-templates/docker/services/swift-storage.yaml      2018-06-05 05:40:17.155000000 -0400
@@ -530,8 +530,11 @@
         - name: Remove rsync service from xinetd
           file: state=absent path=/etc/xinetd.d/rsync
           when: step|int == 2
+          register: rsync_service_removed
         - name: Restart xinetd service after rsync removal
-          when: step|int == 2
+          when:
+            - step|int == 2
+            - rsync_service_removed|changed
           service: name=xinetd state=restarted
       update_tasks:
         - name: Ensure rsyncd pid file is absent


Reassigning to DFG:Storage, Christian could U please continue with proper triage  and fix.

Comment 4 mathieu bultel 2018-06-06 20:46:17 UTC
Hi Maria,

Can you put your ack on this one plz ?

Comment 11 errata-xmlrpc 2018-06-27 13:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.