Bug 158613 - Openoffice.org-core looking for libjawt.so.6, which doesn't exist
Openoffice.org-core looking for libjawt.so.6, which doesn't exist
Status: CLOSED DUPLICATE of bug 158485
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-23 19:54 EDT by Ryan Skadberg
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-24 09:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Skadberg 2005-05-23 19:54:04 EDT
The end of the yum output when trying to install openoffice:


--> Running transaction check
--> Processing Dependency: libjawt.so.6 for package: openoffice.org-core
--> Finished Dependency Resolution
Error: Missing Dependency: libjawt.so.6 is needed by package openoffice.org-core
Comment 1 Robert Williams 2005-05-24 08:51:23 EDT
This message began to appear on the morning of Monday,
May 23.  Not knowing precicely what is causing this,
it appears that libjawt.so.6 is not included
in the most recent update for libgcj.i386 and that 
several new packages require it.   The dependencies
are blocking the update of about 25 packages, including
gcc.   Openoffice.org-core and other packages can be updated
by excluding libgcj and its dependencies, which includes gcc,
but doing this gets old quickly.

I see this:
[root@cpmd ~]# yum list available libgcj
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 985 kB    00:03
developmen: ################################################## 3600/3600
Added 156 new packages, deleted 162 old in 2.93 seconds
Available Packages
libgcj.i386                              4.0.0-8                development
[root@cpmd ~]# yum list available libgcj
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 985 kB    00:03
developmen: ################################################## 3600/3600
Added 156 new packages, deleted 162 old in 2.93 seconds
Available Packages
libgcj.i386                              4.0.0-8                development
[root@cpmd ~]# yum update libgcj
Setting up Update Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libgcj.i386 0:4.0.0-8 set to be updated
--> Running transaction check
--> Processing Dependency: libgcj = 4.0.0-7 for package: gcc-java
--> Processing Dependency: libgcj = 4.0.0-7 for package: libgcj-devel
--> Processing Dependency: libjawt.so.6 for package: openoffice.org-core
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gcc-java.i386 0:4.0.0-8 set to be updated
---> Package libgcj-devel.i386 0:4.0.0-8 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 4.0.0-8 for package: gcc-java
--> Processing Dependency: libjawt.so.6 for package: openoffice.org-core
--> Restarting Dependency Resolution with new changes.                   
--> Populating transaction set with selected packages. Please wait.
---> Package gcc.i386 0:4.0.0-8 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 4.0.0-7 for package: gcc-gfortran
--> Processing Dependency: cpp = 4.0.0-8 for package: gcc
--> Processing Dependency: libjawt.so.6 for package: openoffice.org-core
--> Processing Dependency: gcc = 4.0.0-7 for package: gcc-c++
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gcc-gfortran.i386 0:4.0.0-8 set to be updated
---> Package gcc-c++.i386 0:4.0.0-8 set to be updated
---> Package cpp.i386 0:4.0.0-8 set to be updated
--> Running transaction check
--> Processing Dependency: libstdc++-devel = 4.0.0-8 for package: gcc-c++
--> Processing Dependency: libstdc++ = 4.0.0-8 for package: gcc-c++
--> Processing Dependency: libjawt.so.6 for package: openoffice.org-core
--> Processing Dependency: libgfortran = 4.0.0-8 for package: gcc-gfortran
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libstdc++-devel.i386 0:4.0.0-8 set to be updated
---> Package libgfortran.i386 0:4.0.0-8 set to be updated
---> Package libstdc++.i386 0:4.0.0-8 set to be updated
--> Running transaction check
--> Processing Dependency: libjawt.so.6 for package: openoffice.org-core
--> Finished Dependency Resolution
Error: Missing Dependency: libjawt.so.6 is needed by package openoffice.org-core
Comment 2 Dan Williams 2005-05-24 09:40:08 EDT

*** This bug has been marked as a duplicate of 158485 ***

Note You need to log in before you can comment on or make changes to this bug.