Bug 1586366 - openshift_cloudprovider_kind is undefined if vsphere cloudprovider is enabled
Summary: openshift_cloudprovider_kind is undefined if vsphere cloudprovider is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Russell Teague
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks: 1548163 1572873
TreeView+ depends on / blocked
 
Reported: 2018-06-06 05:50 UTC by Gan Huang
Modified: 2018-07-30 19:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Any task files which are dynamically included must use include_tasks instead of import_tasks due to the dynamic nature of the include.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:17:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:17:58 UTC

Description Gan Huang 2018-06-06 05:50:42 UTC
Description of problem:
If enabling vsphere cloudprivider, installer failed at:

TASK [openshift_cloud_provider : include the defined cloud provider files] *****
task path: /home/slave2/workspace/Run-Ansible-Playbooks-Nextge/private-openshift-ansible/roles/openshift_cloud_provider/tasks/main.yml:13
fatal: [qe-ghuang-master-etcd-nfs-1.0605-l37.qe.rhcloud.com]: FAILED! => {
    "failed": true, 
    "reason": "'openshift_cloudprovider_kind' is undefined"
}
fatal: [qe-ghuang-node-registry-router-1.0605-l37.qe.rhcloud.com]: FAILED! => {
    "failed": true, 
    "reason": "'openshift_cloudprovider_kind' is undefined"

Version-Release number of the following components:
openshift-ansible-3.10.0-0.60.0.git.0.bf95bf8.el7.noarch.rpm
ansible-2.4.4.0-1.el7ae.noarch

How reproducible:
always

Steps to Reproduce:
1. Trigger installation against Vsphere with cloudprovider enabled


Actual results:
Error out: "'openshift_cloudprovider_kind' is undefined"

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Gan Huang 2018-06-06 07:16:21 UTC
This is blocking the test with Vsphere cloudprovider.

Comment 4 Russell Teague 2018-06-06 14:42:50 UTC
Proposed: https://github.com/openshift/openshift-ansible/pull/8654

Comment 5 openshift-github-bot 2018-06-06 16:32:43 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/d9a49a450747759891c6cb5f6d8412cdb92dabb6
Bug 1586366 - Use include_tasks for dynamic task file includes

Any task files which are dynamically included must use include_tasks
instead of import_tasks due to the dynamic nature of the include.

https://github.com/openshift/openshift-ansible/commit/a76d50eb57e920e0521ce6ae19cb3bf0bcb69682
Merge pull request #8654 from mtnbikenc/fix-1586366

Bug 1586366 - Use include_tasks for dynamic task file includes

Comment 7 Gan Huang 2018-06-07 03:00:05 UTC
Verified in openshift-ansible-3.10.0-0.63.0.git.0.961c60d.el7.noarch.rpm

Comment 9 errata-xmlrpc 2018-07-30 19:17:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.