This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 158652 - camstream fails to rebuild on ppc
camstream fails to rebuild on ppc
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: camstream (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: FE4Target
  Show dependency treegraph
 
Reported: 2005-05-24 11:49 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 02:54:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
full build log for ppc failure (64.91 KB, text/x-log)
2005-05-24 12:45 EDT, Colin Charles
no flags Details
spec file patch to make it -ppc (916 bytes, patch)
2005-05-24 13:52 EDT, Colin Charles
no flags Details | Diff

  None (edit)
Description Jeremy Katz 2005-05-24 11:49:33 EDT
Fails to rebuild on PPC, log at 
http://extras64.linux.duke.edu/failed/development/camstream/0.26.3-7/ppc/
Comment 1 Colin Charles 2005-05-24 12:43:53 EDT
Turns out this is in relation to asm issues in camstream (that are x86
specific). Looking at video_asm.S to fix would be necessary. Attaching a full
build failure
Comment 2 Colin Charles 2005-05-24 12:45:29 EDT
Created attachment 114786 [details]
full build log for ppc failure
Comment 3 Colin Charles 2005-05-24 13:51:34 EDT
Now, going by precedent, till we get a nice PPC patch, we should do what others
do (in this case, gentoo -
http://packages.gentoo.org/ebuilds/?camstream-0.26.3). Attached diff is a patch
that can be applied, provided owner is happy...
Comment 4 Colin Charles 2005-05-24 13:52:43 EDT
Created attachment 114789 [details]
spec file patch to make it -ppc
Comment 5 Jeremy Katz 2005-05-24 15:09:17 EDT
That sounds sane to me.  Colin, feel free to commit and queue the build
(preferably also referencing a bug # left open about the need to port the asm to
ppc)
Comment 6 Colin Charles 2005-05-25 21:28:36 EDT
Okay, built on x86/x86_64, excluded PPC for now. Maintainer, are you around?
#157509 in question...

Note You need to log in before you can comment on or make changes to this bug.