Bug 158664 - NetworkManager lacks a panel applet
NetworkManager lacks a panel applet
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-24 13:54 EDT by Jack Aboutboul
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-03 17:22:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jack Aboutboul 2005-05-24 13:54:01 EDT
Description of problem:
NetworkManager lacks a panel applet which therefore requires a user to run
NetworkManagerInfo from a terminal.  This is a usabililty issue that should be
taken care of.  Many users have complained about the lack of an applet and many
have also stated that there is lack of documentation about how to get
NetworkManager working with an applet, not realizing they need to run Info.

Version-Release number of selected component (if applicable):
NetworkManager-0.4-15.cvs20050404

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
As stated, there should be a way to add a NetworkManagerInfo applet to the panel
.  Another solution would be to have Info run with the X login scripts, this way
whenever a user logs in, they get Info on their panel.

Additional info:
Comment 1 Dan Williams 2005-06-29 12:48:57 EDT
The problem here is that its quite hard to add stuff to the user's session
without hardcoding it like we do for up2date and others...

ray, any ideas, or do we punt this one to FC5 ?
Comment 2 Ray Strode [halfline] 2005-06-29 13:24:08 EDT
So there are really three options I think.

1) Add it to the default session and all new users get access to it, but
existing users have to run it themselves.

2) Hard code it in main.c of gnome-session like we do for other services currently.

3) Wait for FC5 and do it using libgnomeservice.


My thought is 3 is the best way to go.  Adding it to the default session in an
FC4 update won't have that much use because if users are updating their systems
they probably already have an account and so won't benefit.  Hard coding it to
main.c is okay with me, but this doesn't actually seem like update material to
me.  People don't expect new features to pop up in updates.  Updates are more
for adding stability.

So I'd say, defer this until FC5 when we'll have a good solution to the problem.
Comment 3 Miles Lane 2006-01-14 02:42:48 EST
I am currently running FC5.  I can find no NetworkManagerInfo.  I have searched
for it with "yum whatprovides" and locate.  Also, I looked for something with
"libgnomeservice" in the filename.  No hits.  NetworkManager and
NetworkManagerDispatcher are not working at all AFAICT, although they are installed.
I have heard that NetworkManager supports WPA/WPA2.  So far, the only network
configuration tool I can locate is system-config-network, which only supports
WEP.  Thus, I cannot configure my WPA2 connection.  So, what happened with this
functionality.  Is there some new plan?
Comment 4 Miles Lane 2006-01-14 03:51:10 EST
Hmm.  I found the instructions for getting nm-applet (sorry for losing track of
your instructions, Dan).  However, there are several problems.  I will contact
you about them seperately.  BTW, it looks like you won't have nm-applet/NM
installed and configured in the default config until FC6.  Is that right?  Thx.
Comment 5 Ray Strode [halfline] 2006-01-16 14:02:23 EST
nm-applet will hide itself if NetworkManager isn't running.  Maybe we should
just run it automatically.

Note You need to log in before you can comment on or make changes to this bug.