Bug 158692 - lvm2 changes for RHEL4 U2
lvm2 changes for RHEL4 U2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On: 158687 159669
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-05-24 17:23 EDT by Alasdair Kergon
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-592
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 11:42:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2005-05-24 17:23:59 EDT
Created to track lvm2-related changes for RHEL4 U2 prior to writing the erratum.
Comment 1 Alasdair Kergon 2005-05-24 17:26:15 EDT
1. Fix hard-coded 65k metadata buffer size.  [158687]
Comment 2 Alasdair Kergon 2005-05-24 17:27:50 EDT
2. Add --ignorelockingfailure to vgmknodes.  Included in 2.01.09.
Comment 4 Alasdair Kergon 2005-05-24 17:36:05 EDT
The following items from 2.01.10 should be included:

3. Move from 2-step to 3-step on-disk metadata commit.

4. Don't create backup and archive dirs till needed.

5. Reinstate full PV size when removing from VG.

6. Support loopfiles for testing.

7. Internal snapshot restructuring.

8. Remove unused internal non-persistent snapshot option.
Comment 5 Alasdair Kergon 2005-05-24 17:43:07 EDT
The following items from (not-yet-released) 2.01.11 should be included:

9. Fix non-orphan pvchange -u.

10. Fix vgmerge to handle duplicate LVIDs.

11. vgscan/change/display/vgs automatically create metadata backups if needed.

12. Simplify pv_maps code and remove slow bitset algorithm.

13. Fix loopfiles alias alloc & mem debugging. [A fix to item 6 above.]

[Some of the other items in the WHATS_NEW file will also get included to support
the items above, but they don't need mentioning separately in the erratum text.]
Comment 7 Alasdair Kergon 2005-06-08 10:19:06 EDT
Item 1 will be fixed in 2.01.11.

Also to be in 2.01.11:

14. Make VG and LV name restrictions consistent.  Names like '.' and '..' don't
work and the tools now stop you using them.  The strings "_mlog" and "_mimage"
can no longer be included in the names of LVs.

15. New '--all' flag added to the 'lvs' and 'vgs' reports.  Without this,
internal LVs are no longer included in the output.  When they are displayed,
their names are enclosed in square brackets.

16. New sanity checks introduced to detect internal coding errors before writing
updated metadata to disk.

17. Reorganise the allocation algorithms to prepare to support mirroring.

18. Support tiny metadata areas to allow for simple metadata conversions from
the GFS 'pool' format.

Comment 11 Alasdair Kergon 2005-06-13 10:24:32 EDT
19. Use selinux matchpathcon 'mode' parameter.  device-mapper package also
needed rebuilding because selinux support got dropped inadvertently.  [bug 159669]
Comment 15 Alasdair Kergon 2005-08-16 10:11:29 EDT
2.0.14 in the release:

20. Prevent snapshots from getting activated in a clustered VG.
21. Fix pool format handler to work with pv segment code (a bug introduced in
this release).
Comment 16 Red Hat Bugzilla 2005-10-05 11:42:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-592.html

Note You need to log in before you can comment on or make changes to this bug.