Bug 1587821 - [APB] `apb list` apb bootstrap` with "--broker" option return 404 Error
Summary: [APB] `apb list` apb bootstrap` with "--broker" option return 404 Error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: David Zager
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-06 07:33 UTC by sunzhaohua
Modified: 2018-07-30 19:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:17:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:17:58 UTC

Description sunzhaohua 2018-06-06 07:33:04 UTC
Description of problem:
In apb-1.2.13 version, `apb list` `apb bootstrap` with "--broker" optionreturn 404 Error.

Version-Release number of selected component (if applicable):
$ apb version
Version: apb-1.2.13

How reproducible:
Always

Steps to Reproduce:
1. #apb list --broker asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com
2. #apb bootstrap --broker asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com
3.

Actual results:
 apb-1.2.13, `apb list` `apb bootstrap` with "--broker" option return 404 error. Re-install apb verion 1.2.10, `apb list` work normally.
 
$ apb version
Version: apb-1.2.13

$ apb list --broker asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com/v2/catalog
Error: Attempt to list APBs in the broker returned status: 404
Unable to list APBs in Ansible Service Broker.

$ apb bootstrap --broker asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com/v2/bootstrap
Error: Attempt to bootstrap Broker returned status: 404
Unable to bootstrap Ansible Service Broker.

$ apb version
Version: apb-1.2.10

$ apb list --broker asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0605-va3.qe.rhcloud.com/ansible-service-broker/v2/catalog
No APBs found


Expected results:
In version apb-1.2.13, `apb list` `apb bootstrap` with "--broker" option work normally.

Additional info:
Contacting the ansible-service-broker url lack of "ansible-service-broker" in apb-1.2.13

Comment 4 Jian Zhang 2018-06-07 09:14:22 UTC
Verify it.

The apb tool version: 1.2.14
[jzhang@localhost ~]$ apb version
Version: apb-1.2.14

Run the `list` and `bootstrap` with `--broker` option, it works well:
[jzhang@localhost ~]$ apb list
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0606-2o7.qe.rhcloud.com/ansible-service-broker/v2/catalog
ID                                NAME               DESCRIPTION                        
2c259ddd8059b9bc65081e07bf20058f  rh-mariadb-apb     Mariadb apb implementation         
03b69500305d9859bb9440d9f9023784  rh-mediawiki-apb   Mediawiki apb implementation       
73ead67495322cc462794387fa9884f5  rh-mysql-apb       Software Collections MySQL APB     
d5915e05b253df421efe6e41fb6a66ba  rh-postgresql-apb  SCL PostgreSQL apb implementation  
[jzhang@localhost ~]$ apb list --broker asb-1338-openshift-ansible-service-broker.apps.0606-2o7.qe.rhcloud.com
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0606-2o7.qe.rhcloud.com/ansible-service-broker/v2/catalog
ID                                NAME               DESCRIPTION                        
2c259ddd8059b9bc65081e07bf20058f  rh-mariadb-apb     Mariadb apb implementation         
03b69500305d9859bb9440d9f9023784  rh-mediawiki-apb   Mediawiki apb implementation       
73ead67495322cc462794387fa9884f5  rh-mysql-apb       Software Collections MySQL APB     
d5915e05b253df421efe6e41fb6a66ba  rh-postgresql-apb  SCL PostgreSQL apb implementation  
[jzhang@localhost ~]$ apb bootstrap
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0606-2o7.qe.rhcloud.com/ansible-service-broker/v2/bootstrap
Successfully bootstrapped Ansible Service Broker
Successfully relisted the Service Catalog
[jzhang@localhost ~]$ apb bootstrap --broker asb-1338-openshift-ansible-service-broker.apps.0606-2o7.qe.rhcloud.com
Contacting the ansible-service-broker at: https://asb-1338-openshift-ansible-service-broker.apps.0606-2o7.qe.rhcloud.com/ansible-service-broker/v2/bootstrap
Successfully bootstrapped Ansible Service Broker
Successfully relisted the Service Catalog

Comment 6 errata-xmlrpc 2018-07-30 19:17:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.