Bug 1587882 - Etcd scale-up playbook couldn't work
Summary: Etcd scale-up playbook couldn't work
Keywords:
Status: CLOSED DUPLICATE of bug 1578482
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-06 08:52 UTC by Gaoyun Pei
Modified: 2018-06-06 14:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-06 14:55:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gaoyun Pei 2018-06-06 08:52:58 UTC
Description of problem:
Run etcd scale-up playbook but failed as below:

TASK [etcd : Add new etcd members to cluster] *******************************************************************************************************************************
fatal: [ec2-34-207-200-174.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "The task includes an option with an undefined variable. The error was: 'dict object' has no attribute 'etcd_ip'\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/roles/etcd/tasks/add_new_member.yml': line 5, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: Add new etcd members to cluster\n  ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'dict object' has no attribute 'etcd_ip'"}


Version-Release number of the following components:
openshift-ansible-3.10.0-0.60.0.git.0.bf95bf8.el7.noarch

How reproducible:
Always


Steps to Reproduce:
1.Add [new_etcd] group in the inventory file, run etcd scale-up playbook
#ansible-playbook -i 310_scale_etcd /usr/share/ansible/openshift-ansible/playbooks/openshift-etcd/scaleup.yml -v


Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Vikas Laad 2018-06-06 14:55:26 UTC
Closing as its dup of existing bug, please see https://bugzilla.redhat.com/show_bug.cgi?id=1578482#c4 and raise the sev of needed on that bz.

*** This bug has been marked as a duplicate of bug 1578482 ***


Note You need to log in before you can comment on or make changes to this bug.