Bug 1588061 - Suspend VM leaves disks as leftover
Summary: Suspend VM leaves disks as leftover
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.4.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.4.7
: 4.4.7
Assignee: Shmuel Melamud
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-06 14:34 UTC by Liran Rotenberg
Modified: 2021-07-11 07:36 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.4.7.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-11 07:36:34 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
engine log (853.66 KB, text/plain)
2018-06-06 14:34 UTC, Liran Rotenberg
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115348 0 master MERGED core: Remove hibernation disks on VM shutdown 2021-06-24 12:15:34 UTC

Description Liran Rotenberg 2018-06-06 14:34:39 UTC
Created attachment 1448356 [details]
engine log

Description of problem:
When creating a VM, suspending it and shutting it down, the suspension disks(hibernation_memory and hibernation_metadata) will stay as leftovers even after VM removal.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.4-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a VM.
2. Start the VM.
3. Enter the VM to suspend.
4. Shutdown the VM.

Actual results:
Two disks are leftovers:
vm_name_hibernation_memory and vm_name_hibernation_metadata

Expected results:
Disk removal when exiting suspend mode. No leftovers.

Comment 1 Sandro Bonazzola 2019-01-28 09:34:41 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 2 Tal Nisan 2019-04-07 09:27:06 UTC
After second look this seems like a Virt flow so moving to Virt for inspection

Comment 3 Nisim Simsolo 2021-07-11 07:28:36 UTC
Verified: 
ovirt-engine-4.4.7.6-0.11.el8ev
vdsm-4.40.70.6-1.el8ev.x86_64
libvirt-daemon-7.0.0-14.1.module+el8.4.0+11095+d46acebf.x86_64
qemu-kvm-5.2.0-16.module+el8.4.0+11536+725e25d9.2.x86_64

Verification scenario:
1. Run VM.
2. Suspend VM. 
observe storage -> disks, verify there are 2 new disks with the next description: 
memory dump for VM hibernation
metadata for VM hibernation
3. Shutdown VM and verify both disks removed. 
4. Repeat steps 1-3 few more times.

Comment 4 Arik 2021-07-11 07:36:34 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.