Bug 1588175 - Unable to load custom roles in UI.
Summary: Unable to load custom roles in UI.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-06 20:49 UTC by Alexander Chuzhoy
Modified: 2018-06-27 13:58 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 573006 None master: NEW tripleo-ui: Pass currentPlanName when fetching available roles (I7fdaa4031d5e093f88c31201ae8ca261469f57a6) 2018-06-07 12:35:28 UTC
OpenStack gerrit 573011 None stable/queens: NEW tripleo-ui: Pass currentPlanName when fetching available roles (I7fdaa4031d5e093f88c31201ae8ca261469f57a6) 2018-06-07 12:35:22 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:58:15 UTC

Description Alexander Chuzhoy 2018-06-06 20:49:12 UTC
Unable to load custom roles in UI.

Environment:
openstack-tripleo-heat-templates-8.0.2-28.el7ost.noarch
openstack-tripleo-ui-8.3.1-2.el7ost.noarch
instack-undercloud-8.4.1-4.el7ost.noarch

Steps to reproduce:

Create a custom composable role under THT/roles.
Create a new plan with tarbal including the custom role.
See the list of roles in UI.

Result:

No composable role in UI.



Also,
tried to update the existing role (Controller.yaml) - removed some services and update the plan with:

openstack object save <plan> roles/Controller.yaml

Checked in UI the services on controller. All still appear.

Comment 1 Jiri Tomasek 2018-06-06 21:11:47 UTC
Added upstream patch fix

Comment 7 Alexander Chuzhoy 2018-06-12 20:32:24 UTC
Verified:

Environment:
openstack-tripleo-ui-8.3.1-3.el7ost.noarch


The reported issue doesn't reproduce.
The composable role is in the list.

Comment 9 errata-xmlrpc 2018-06-27 13:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.