Bug 1588192 - Client (and hence also server) FreeIPA enrolment broken by rename of 'fedora-domainname' service to 'nis-domainname'
Summary: Client (and hence also server) FreeIPA enrolment broken by rename of 'fedora-...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1584645
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-06-06 22:08 UTC by Adam Williamson
Modified: 2018-06-21 18:37 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-21 18:37:46 UTC


Attachments (Terms of Use)

Description Adam Williamson 2018-06-06 22:08:17 UTC
This is a downstream bug for https://pagure.io/freeipa/issue/7582 : FreeIPA client deployment on Rawhide is broken because the 'fedora-domainname' service was renamed to 'nis-domainname' in initscripts 9.81. (The service was subsequently moved to the hostname package, but this shouldn't cause any problems).

This is a clear F29 Beta blocker as it prevents deployment of the 'domain controller' role.

Comment 1 Rob Crittenden 2018-06-07 20:48:55 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7582

Comment 2 Christian Heimes 2018-06-15 06:31:51 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/907e1649580b8677d56da6207731addc178dca80

Comment 3 Adam Williamson 2018-06-21 18:37:46 UTC
Confirmed fixed in 20180620.n.0 compose testing, all FreeIPA-related tests now pass.


Note You need to log in before you can comment on or make changes to this bug.