Bug 15883 - chage doesn't understand YYYY-MM-DD format - contrary to man page
chage doesn't understand YYYY-MM-DD format - contrary to man page
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 15:07 EDT by John Dalbec
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 15:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dalbec 2000-08-09 15:07:10 EDT
According to the man page, chage should understand dates in the format YYYY-MM-DD.
This does not appear to work.  Instead, chage interprets YYYY-MM-DD to mean YYYY days since the epoch.
MM and DD are ignored.  However, YYYY/MM/DD works fine.  I have observed this only on the S/390 platform,
but the source only looks for a date if it has a "/" in it.
You could (a) fix chage to look for dates with hyphens
or (b) fix the man page to say YYYY/MM/DD.
Thanks,
John
Comment 1 Bernhard Rosenkraenzer 2000-08-30 09:33:10 EDT
Fixed in 20000826-2.

Note You need to log in before you can comment on or make changes to this bug.