Bug 1588326 - CloudForms : Wrong heading message while accessing Cloud Networks
Summary: CloudForms : Wrong heading message while accessing Cloud Networks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Greg Piatigorski
QA Contact: Nikhil Dhandre
URL:
Whiteboard:
Depends On:
Blocks: 1578510 1599353
TreeView+ depends on / blocked
 
Reported: 2018-06-07 05:35 UTC by Imaan
Modified: 2019-02-11 13:59 UTC (History)
13 users (show)

Fixed In Version: 5.10.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1599353 (view as bug list)
Environment:
Last Closed: 2019-02-11 13:59:09 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Imaan 2018-06-07 05:35:46 UTC
Description of problem:

While accessing Cloud Networks from instance relationship table, the wrong message is shown as "Cloud Subnets" for Instance "Instance Name"

Version-Release number of selected component (if applicable):

Version 5.9.2.4.20180501195858_35dc609

How reproducible: 100%

Steps to Reproduce:

1. Login To CloudForms Operational Portal

2. Navigate to compute-> cloud -> instance -> click on any instance -> Click on Cloud Networks (under relationships)
 
3. You will get the wrong message.

Actual results:

Wrong Message: "Cloud Subnets" for Instance "Instance Name"

Expected results:

"Cloud Networks" for Instance "Instance Name"

Comment 6 Greg Piatigorski 2018-07-03 20:35:20 UTC
Working on the fix. Common code issue, change, if not properly applied, will affect other UI pages since same code handles how page header is built. Trying to get this done today, need a bit more analysis and testing first.

Comment 8 CFME Bot 2018-07-06 17:54:39 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/f55b1c5abddc3954104a573e78decf41b3c9a0e9
commit f55b1c5abddc3954104a573e78decf41b3c9a0e9
Author:     Greg Piatigorski <gpiatigo@gmail.com>
AuthorDate: Thu Jul  5 19:01:49 2018 -0400
Commit:     Greg Piatigorski <gpiatigo@gmail.com>
CommitDate: Thu Jul  5 19:01:49 2018 -0400

    Fixes page header when displaying Cloud Networks list

    https://bugzilla.redhat.com/show_bug.cgi?id=1588326

 app/controllers/vm_common.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 10 Nikhil Dhandre 2018-08-02 11:07:57 UTC
Tested with Version 5.10.0.6.20180725145922_d299ff5

"Cloud Networks" for Instance "cu-24x7"


Note You need to log in before you can comment on or make changes to this bug.