Bug 1588367 - no music in openttd due to missing dependency on timidity++
Summary: no music in openttd due to missing dependency on timidity++
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openttd
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Kaechele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-07 07:30 UTC by Kamil Páral
Modified: 2022-10-06 16:20 UTC (History)
2 users (show)

Fixed In Version: openttd-1.8.0-3.fc27 openttd-1.8.0-3.fc28 openttd-12.2-4.fc38 openttd-12.2-4.fc37 openttd-12.2-4.fc36 openttd-12.2-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-03 00:19:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Kamil Páral 2018-06-07 07:30:13 UTC
Description of problem:
When I install 'openttd' on a cleanly installed computer, run openttd, install OpenMSX, enable it and start the jukebox, there's no music played and the jukebox scrolls through all available songs rapidly. The only way to fix this is to install 'timidity++' package. Then openttd finally plays music, and in the process viewer I can clearly see that openttd has started a process 'timidity <path>.mid'.

The openttd package is missing a dependency on the timidity++ package, so that music can be played.

Version-Release number of selected component (if applicable):
openttd-1.8.0-1.fc28.x86_64

How reproducible:
always

Steps to Reproduce:
1. run openttd without timidity++ installed, see that no music can be played
2. install timidity++, see that music can be played

Comment 1 Fedora Update System 2018-06-07 09:20:00 UTC
openttd-1.8.0-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-68b2ca6ab7

Comment 2 Fedora Update System 2018-06-07 09:20:07 UTC
openttd-1.8.0-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4d44caf7f7

Comment 3 Fedora Update System 2018-06-07 11:20:39 UTC
openttd-1.8.0-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-68b2ca6ab7

Comment 4 Fedora Update System 2018-06-07 13:19:08 UTC
openttd-1.8.0-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4d44caf7f7

Comment 5 Fedora Update System 2018-06-15 14:58:20 UTC
openttd-1.8.0-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2018-06-15 15:49:24 UTC
openttd-1.8.0-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Joshua Noeske 2022-09-18 11:18:24 UTC
This problem still persists, even with Fedora 36 and the newest version of the package. I just installed it and timidity++ was not installed as a dependency, so the sound was not working. No that I installed it, the music works.

Comment 8 Felix Kaechele 2022-09-18 14:57:23 UTC
Thanks for reporting this.

OpenTTD on Fedora should be using fluidsynth instead of timidity++ these days. It's possible that no fluidsynth soundfont was installed when OpenTTD was installed.
Could you check that fluid-soundfont-gm is installed?

FWIW, everything is working fine on my machine and I do not have timidity++ installed.

Comment 9 Kamil Páral 2022-09-19 08:23:37 UTC
This is indeed broken again. On a clean F36 Workstation install:

$ sudo dnf install openttd
Last metadata expiration check: 0:00:57 ago on Mon 19 Sep 2022 10:06:03 AM CEST.
Dependencies resolved.
==============================================================================
 Package               Architecture Version               Repository     Size
==============================================================================
Installing:
 openttd               x86_64       12.2-1.fc36           updates       6.0 M
Installing dependencies:
 fluidsynth-libs       x86_64       2.2.9-2.fc36          updates       224 k
Installing weak dependencies:
 openttd-opengfx       noarch       7.1-2.fc36            fedora        3.0 M

After installing it:

$ rpm -q fluid-soundfont-gm
package fluid-soundfont-gm is not installed

When openttd is run:

$ openttd
fluidsynth: error: fluid_is_soundfont(): fopen() failed: 'File does not exist.'

When OpenMSX is installed, the music doesn't play. After installing fluid-soundfont-gm, the music plays as expected.

So either openttd needs to depend on fluid-soundfont-gm, or fluidsynth-libs need to depend on it.

There are already some packages which require fluid-soundfont-gm:

$ sudo dnf repoquery --whatrequires fluid-soundfont-gm
dosbox-staging-0:0.78.1-3.fc37.x86_64
fluid-soundfont-gs-0:3.1-27.fc37.noarch
gstreamer1-plugins-bad-free-fluidsynth-0:1.20.3-2.fc37.i686
gstreamer1-plugins-bad-free-fluidsynth-0:1.20.3-2.fc37.x86_64
mscore-0:3.6.2-10.fc37.x86_64
qsynth-0:0.9.7-2.fc37.x86_64
timidity++-0:2.15.0-4.fc37.x86_64
tuxguitar-0:1.5.4-5.fc37.x86_64
vmpk-0:0.8.7-3.fc37.x86_64

And fluidsynth (but not fluidsynth-libs!) actually recommends fluid-soundfont-gm:
$ sudo dnf repoquery --whatrecommends fluid-soundfont-gm
fluidsynth-0:2.2.8-2.fc37.x86_64
fluidsynth-0:2.2.9-2.fc37.x86_64

I'm not sure if it makes sense for some app to depend on fluidsynth-libs but not actually require fluid-soundfont-gm. It if makes sense, openttd needs to add fluid-soundfont-gm as its own requirement. If it doesn't make sense, we can file a bug against fluidsynth-libs to at least recommend fluid-soundfont-gm directly.

Comment 10 Joshua Noeske 2022-09-19 11:22:36 UTC
Thanks for the quick responses. Indeed, the actual reason why the install of timidity++ fixed it is that it installs fluid-soundfont-gm as dependency. After installing only fluid-soundfont-gm it works for me as well.

Comment 11 Felix Kaechele 2022-09-19 11:44:24 UTC
fluidsynth has a weak dependency on fluid-soundfont-gm but fluidsynth-libs does not. Since fluidsynth-libs is an automatically tracked library dependency for openttd it never installs fluidsynth and thus also no fluid-soundfont-gm.

I think the best way forward for openttd is to put a weak dependency on fluid-soundfont-gm as well. I'll do that with the next update.

Comment 12 Fedora Update System 2022-09-25 01:35:55 UTC
FEDORA-2022-29dfe9792b has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-29dfe9792b

Comment 13 Fedora Update System 2022-09-25 01:39:38 UTC
FEDORA-2022-29dfe9792b has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Kamil Páral 2022-09-26 09:04:39 UTC
Can you please also fix this in F35-F37? Thanks.

Comment 15 Fedora Update System 2022-09-28 02:23:43 UTC
FEDORA-2022-a9a64d3b5c has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a9a64d3b5c

Comment 16 Fedora Update System 2022-09-28 02:23:43 UTC
FEDORA-2022-956fe13e02 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-956fe13e02

Comment 17 Fedora Update System 2022-09-28 02:25:45 UTC
FEDORA-2022-b048bd8560 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b048bd8560

Comment 18 Fedora Update System 2022-09-29 04:17:15 UTC
FEDORA-2022-a9a64d3b5c has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-a9a64d3b5c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a9a64d3b5c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-09-29 04:39:07 UTC
FEDORA-2022-b048bd8560 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-b048bd8560`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b048bd8560

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2022-09-29 05:01:03 UTC
FEDORA-2022-956fe13e02 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-956fe13e02`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-956fe13e02

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-10-03 00:19:52 UTC
FEDORA-2022-b048bd8560 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2022-10-06 15:14:41 UTC
FEDORA-2022-a9a64d3b5c has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2022-10-06 16:20:16 UTC
FEDORA-2022-956fe13e02 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.