Bug 1588442 - New version of Siril
Summary: New version of Siril
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: siril
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christian Dersch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-07 11:09 UTC by cyril
Modified: 2018-07-15 03:31 UTC (History)
3 users (show)

Fixed In Version: siril-0.9.9-2.fc27 siril-0.9.9-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-14 23:35:40 UTC


Attachments (Terms of Use)
Build log (35.67 KB, text/plain)
2018-06-15 10:41 UTC, Christian Dersch
no flags Details
Patch for fedora builds against glibc2.48 (3.00 KB, patch)
2018-07-04 09:06 UTC, cyril
no flags Details | Diff
Patch for fedora builds against glibc2.48 (2nd try) (2.66 KB, patch)
2018-07-04 09:14 UTC, cyril
no flags Details | Diff

Description cyril 2018-06-07 11:09:48 UTC
@Christian Dersch:
A new upstream version of Siril is available at https://free-astro.org/download/siril-0.9.9.tar.bz2

Could you take a look for building package ?

Comment 1 Christian Dersch 2018-06-15 10:41:21 UTC
Created attachment 1451885 [details]
Build log

Comment 2 Christian Dersch 2018-06-15 10:43:03 UTC
Unfortunately the package fails to build on Rawhide :( Complete build log in attachment. Failure: 


gcc -DHAVE_CONFIG_H -I. -I..  -DPACKAGE_DATA_DIR='"/usr/share/siril"' -DPACKAGE_DOC_DIR='"/usr/share/doc/siril"' -DLOCALEDIR='"/usr/share/locale"'  -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/uuid -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/libdrm -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -pthread    -I/usr/include/libpng16   -D_REENTRANT -I/usr/include/cfitsio     -I ../deps/kplot   -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fopenmp -c -o core/utils.o core/utils.c
In file included from core/utils.c:63:
./core/proto.h:184:5: error: conflicting types for 'fdiv'
 int fdiv(fits *a, fits *b, float scalar);
     ^~~~
In file included from core/utils.c:60:
/usr/include/bits/mathcalls-narrow.h:27:20: note: previous declaration of 'fdiv' was here
 __MATHCALL_NARROW (__MATHCALL_NAME (div), __MATHCALL_REDIR_NAME (div), 2);
                    ^~~~~~~~~~~~~~~
In file included from core/utils.c:63:
./core/proto.h:186:5: error: conflicting types for 'fmul'
 int fmul(fits *a, float coeff);
     ^~~~
In file included from core/utils.c:60:
/usr/include/bits/mathcalls-narrow.h:30:20: note: previous declaration of 'fmul' was here
 __MATHCALL_NARROW (__MATHCALL_NAME (mul), __MATHCALL_REDIR_NAME (mul), 2);
                    ^~~~~~~~~~~~~~~
make[2]: *** [Makefile:867: core/utils.o] Error 1
make[2]: Leaving directory '/builddir/build/BUILD/siril-0.9.9/src'
make[2]: *** Waiting for unfinished jobs....

Comment 3 Christian Dersch 2018-06-15 10:45:57 UTC
First guess: As the build only fails in rawhide, I think it is related to this change in glibc https://sourceware.org/git/?p=glibc.git;a=commit;h=69a01461ee1417578d2ba20aac935828b50f1118

Comment 4 cyril 2018-06-15 16:15:30 UTC
The easiest way is to change the name (and all the calls) of fdiv and fmul.
I could do it in the next upstream release but I would like to reproduce ... I can't.

But we also should try to add these lines in a patch
#ifdef fdiv
#undef fdiv

#ifdef fmul
#undef fmul

Comment 5 cyril 2018-06-24 19:27:25 UTC
is the bug fixed ?

Comment 6 Christian Dersch 2018-07-03 13:09:06 UTC
No, I was on vacation and will not have for next few weeks. Can you provide a patch? To reproduce you have to build against a glibc 2.28 pre-release, like in Fedora rawhide. The release of 2.28 is expected in ~4 weeks.

Comment 7 cyril 2018-07-04 09:06:50 UTC
Created attachment 1456436 [details]
Patch for fedora builds against glibc2.48

Comment 8 cyril 2018-07-04 09:09:11 UTC
Ok. Patch added. Please let me know.

Comment 9 cyril 2018-07-04 09:14:38 UTC
Created attachment 1456441 [details]
Patch for fedora builds against glibc2.48 (2nd try)

Comment 10 Christian Dersch 2018-07-04 09:32:23 UTC
Looks like this works fine, thanks!

Rawhide build: https://koji.fedoraproject.org/koji/taskinfo?taskID=28014856

Once it has finished I can create the updates for Fedora 27 and 28.

Comment 11 Fedora Update System 2018-07-04 10:14:06 UTC
siril-0.9.9-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-faedcbe1fa

Comment 12 Fedora Update System 2018-07-04 10:14:15 UTC
siril-0.9.9-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-629277d9bb

Comment 13 Fedora Update System 2018-07-04 16:23:40 UTC
siril-0.9.9-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-faedcbe1fa

Comment 14 Fedora Update System 2018-07-04 18:22:30 UTC
siril-0.9.9-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-629277d9bb

Comment 15 Fedora Update System 2018-07-14 23:35:40 UTC
siril-0.9.9-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-07-15 03:31:57 UTC
siril-0.9.9-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.