Bug 1588471 - nothing provides python-rhsm needed by pulp-rpm-handlers-2.15.2-1.fc28.noarch
Summary: nothing provides python-rhsm needed by pulp-rpm-handlers-2.15.2-1.fc28.noarch
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulp-rpm
Version: 28
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Ina Panova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: oVirt_on_Fedora
TreeView+ depends on / blocked
 
Reported: 2018-06-07 12:15 UTC by Sandro Bonazzola
Modified: 2018-07-16 07:12 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-07-16 07:12:19 UTC


Attachments (Terms of Use)

Description Sandro Bonazzola 2018-06-07 12:15:35 UTC
dnf install pulp-rpm-handlers
Failed to synchronize cache for repo 'cqi-rhmsg', disabling.
Last metadata expiration check: 0:00:18 ago on Thu Jun  7 14:13:51 2018.
Error: 
 Problem: conflicting requests
  - nothing provides python-rhsm needed by pulp-rpm-handlers-2.15.2-1.fc28.noarch


It should probably require python3-subscription-manager-rhsm instead.

Comment 1 Sandro Bonazzola 2018-06-07 12:21:18 UTC
pulp-rpm-handlers is needed in order to run katello-agent on Fedora systems.

Comment 2 Patrick Creech 2018-06-07 13:02:47 UTC
Are you using the fedora repos for pulp or are you using katello's repos?

Either way, this bug is still valid for fedora, just making sure it gets reported in all the appropriate areas.

The issue here is pulp 2.y is not and will not be python3 compatible.  We are waiting on a python2 version of python-subscription-manager-rhsm to land, I have been in contact with the candlepin team about delivering it.

Comment 3 Sandro Bonazzola 2018-06-07 16:20:19 UTC
(In reply to Patrick Creech from comment #2)
> Are you using the fedora repos for pulp or are you using katello's repos?
> 
> Either way, this bug is still valid for fedora, just making sure it gets
> reported in all the appropriate areas.
> 
> The issue here is pulp 2.y is not and will not be python3 compatible.  We
> are waiting on a python2 version of python-subscription-manager-rhsm to
> land, I have been in contact with the candlepin team about delivering it.

I'm using https://copr.fedorainfracloud.org/coprs/sbonazzo/ovirt-katello/ which is a rebuild of the Fedora 26 src rpm coming from https://fedorapeople.org/groups/katello/releases/source/srpm/3.6/client/f26/katello-host-tools-3.0.2-1.fc26.src.rpm on top of Fedora.

I understand the requirement on being python3 compatible, but at this level it looks more like a package renaming.
Note that https://koji.fedoraproject.org/koji/buildinfo?buildID=1078192 from May 1st 2018 has python2 version of python-subscription-manager-rhsm so I think you can require it even if pulp-2.y is not python 3 ready.

Comment 4 Patrick Creech 2018-06-07 17:22:52 UTC
Yes, the plan is to depend on python2-subscription-manager-rhsm.  

The issue is, this package is not available from the published fedora repos at this time, and I've been working with candlepin on getting this into fedora28 asap.

Comment 5 Patrick Creech 2018-06-08 13:57:55 UTC
The following bodhi update to the required library shoud resolve the issue:

https://bodhi.fedoraproject.org/updates/FEDORA-2018-b93c0d8968

I've been told that it should have a 'Provides: python-rhsm' of some sort, so we hopefully shouldn't need to update anything in pulp's rpms for this dependency to be satisfied again.

I'll keep this bz open though until it is determined that this is the case.  If not, we'll use this bz to track the needed change to requires.

Comment 6 Sandro Bonazzola 2018-06-12 14:34:20 UTC
It has the "Provides: python-rhsm" line and works for me. Added karma +1.

Comment 7 Sandro Bonazzola 2018-06-15 06:22:41 UTC
(In reply to Patrick Creech from comment #5)
> The following bodhi update to the required library shoud resolve the issue:
> 
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-b93c0d8968

Works for me, I gave karma +1. Waiting to see this in stable.


> 
> I've been told that it should have a 'Provides: python-rhsm' of some sort,
> so we hopefully shouldn't need to update anything in pulp's rpms for this
> dependency to be satisfied again.
> 
> I'll keep this bz open though until it is determined that this is the case. 
> If not, we'll use this bz to track the needed change to requires.

Comment 8 Sandro Bonazzola 2018-07-16 07:12:19 UTC
Closing this bug since provided solution works for me now.


Note You need to log in before you can comment on or make changes to this bug.