Bug 1588668 - Cannot upgrade to bacula 9.0.7
Summary: Cannot upgrade to bacula 9.0.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bacula
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-07 17:18 UTC by Paul Johnson
Modified: 2018-06-15 15:51 UTC (History)
8 users (show)

Fixed In Version: bacula-9.0.7-6.fc27 bacula-9.0.7-6.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-15 14:58:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Johnson 2018-06-07 17:18:30 UTC
Description of problem:

I have bacula-9.0.6 installed. When I try to do "dnf update" I get the following:

dnf update
Last metadata expiration check: 0:53:33 ago on Thu 07 Jun 2018 16:57:39 BST.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package bacula-director-9.0.6-8.fc28.x86_64
  - nothing provides libbaccats-9.0.7.so()(64bit) needed by bacula-director-9.0.7-3.fc28.x86_64
 Problem 2: cannot install the best update candidate for package bacula-storage-9.0.6-8.fc28.x86_64
  - nothing provides libbaccats-9.0.7.so()(64bit) needed by bacula-storage-9.0.7-3.fc28.x86_64
 Problem 3: problem with installed package bacula-storage-9.0.6-8.fc28.x86_64
  - package bacula-storage-9.0.6-8.fc28.x86_64 requires bacula-common(x86-64) = 9.0.6-8.fc28, but none of the providers can be installed
  - cannot install both bacula-common-9.0.7-3.fc28.x86_64 and bacula-common-9.0.6-8.fc28.x86_64
  - cannot install both bacula-common-9.0.6-8.fc28.x86_64 and bacula-common-9.0.7-3.fc28.x86_64
  - cannot install the best update candidate for package bacula-common-9.0.6-8.fc28.x86_64
  - nothing provides libbaccats-9.0.7.so()(64bit) needed by bacula-storage-9.0.7-3.fc28.x86_64
 Problem 4: problem with installed package bacula-director-9.0.6-8.fc28.x86_64
  - package bacula-director-9.0.6-8.fc28.x86_64 requires bacula-libs(x86-64) = 9.0.6-8.fc28, but none of the providers can be installed
  - package bacula-director-9.0.6-8.fc28.x86_64 requires libbac-9.0.6.so()(64bit), but none of the providers can be installed
  - cannot install both bacula-libs-9.0.7-3.fc28.x86_64 and bacula-libs-9.0.6-8.fc28.x86_64
  - cannot install both bacula-libs-9.0.6-8.fc28.x86_64 and bacula-libs-9.0.7-3.fc28.x86_64
  - cannot install the best update candidate for package bacula-libs-9.0.6-8.fc28.x86_64
  - nothing provides libbaccats-9.0.7.so()(64bit) needed by bacula-director-9.0.7-3.fc28.x86_64
==========================================================================================================
 Package                      Arch                Version                      Repository            Size
==========================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 bacula-common                x86_64              9.0.7-3.fc28                 updates               36 k
 bacula-libs                  x86_64              9.0.7-3.fc28                 updates              501 k
Skipping packages with broken dependencies:
 bacula-director              x86_64              9.0.7-3.fc28                 updates              400 k
 bacula-storage               x86_64              9.0.7-3.fc28                 updates              185 k

Transaction Summary
==========================================================================================================
Skip  4 Packages

Nothing to do.
Complete!

Version-Release number of selected component (if applicable):


How reproducible:

Every time. Problem persists if I deinstall and reinstall the bacula packages.

Steps to Reproduce:
1. dnf install bacula-director bacula-storage bacula-common bacula-libs
2. Note that installed bacula packages are all version 9.0.6
3. dnf update

Actual results:

As above.

Expected results:

bacula packages with version equal to 9.0.7 are installed.

Additional info:

This is a follow-on to #1577186. While the 9.0.7 was in testing I forced dnf to install it and verified that the bat program was now present, but there were other version incompatibilities that prevented me from running it unless I wanted to upgrade more of my system to "testing", which I didn't want to do.

Comment 1 Paul Howarth 2018-06-09 09:57:34 UTC
Same/similar issue on Fedora 27. Nothing provides libbaccats-9.0.7.so()(64bit). The libs-sql package provides:

libbaccats-mysql-9.0.7.so()(64bit)
libbaccats-postgresql-9.0.7.so()(64bit)
libbaccats-sqlite3-9.0.7.so()(64bit)

but not libbaccats-9.0.7.so()(64bit), which is required by bacula-director.

Comment 2 Fedora Update System 2018-06-11 12:03:49 UTC
bacula-9.0.7-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5156ca7a45

Comment 3 Fedora Update System 2018-06-11 12:04:04 UTC
bacula-9.0.7-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-98ccf382ee

Comment 4 Steven A. Falco 2018-06-11 13:55:17 UTC
This appears to be a duplicate of Bug 1588514. I suggest marking this one as a dup.

Comment 5 Fedora Update System 2018-06-11 14:53:15 UTC
bacula-9.0.7-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5156ca7a45

Comment 6 Fedora Update System 2018-06-14 05:03:56 UTC
bacula-9.0.7-6.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-eb96865a46

Comment 7 Fedora Update System 2018-06-14 05:04:14 UTC
bacula-9.0.7-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f4cc6b44a5

Comment 8 Fedora Update System 2018-06-14 18:23:04 UTC
bacula-9.0.7-6.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-eb96865a46

Comment 9 Fedora Update System 2018-06-14 20:23:56 UTC
bacula-9.0.7-6.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f4cc6b44a5

Comment 10 Fedora Update System 2018-06-15 14:58:28 UTC
bacula-9.0.7-6.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-06-15 15:51:24 UTC
bacula-9.0.7-6.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.