Bug 1588731 - Bucket lifecycles stick around after buckets are deleted
Summary: Bucket lifecycles stick around after buckets are deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z1
: 3.2
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
Erin Donnelly
URL:
Whiteboard:
Depends On:
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-06-07 18:41 UTC by Orit Wasserman
Modified: 2019-03-07 15:51 UTC (History)
12 users (show)

Fixed In Version: RHEL: ceph-12.2.8-3.el7cp Ubuntu: ceph_12.2.8-3redhat1
Doc Type: Bug Fix
Doc Text:
.Stale lifecycle configuration data of deleted buckets no longer persists in `OMAP` consuming space Previously, in the Ceph Object Gateway (RGW), incorrect key formatting in the `RGWDeleteLC::execute()`function caused bucket lifecycle configuration metadata to persist after the deletion of the corresponding bucket. This caused stale lifecycle configuration data to persist in `OMAP` consuming space. With this update, the correct name for the lifecycle object is now used in `RGWDeleteLC::execute()`, and the lifecycle configuration is removed as expected on removal of the corresponding bucket.
Clone Of:
Environment:
Last Closed: 2019-03-07 15:50:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0475 None None None 2019-03-07 15:51:06 UTC
Ceph Project Bug Tracker 19632 None None None 2018-06-07 18:41:56 UTC

Description Orit Wasserman 2018-06-07 18:41:56 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2. 
3.

Actual results:


Expected results:


Additional info:

Comment 5 Karun Josy 2018-11-09 04:38:31 UTC
Hi Matt,

When we were testing bucket lifecycle policies related to a case opened by a customer, we hit the same bug.

As far as I understand this bug is resolved and backported in Upstream.
Can you let me know when this will be available in downstream?

Comment 18 errata-xmlrpc 2019-03-07 15:50:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475


Note You need to log in before you can comment on or make changes to this bug.