Bug 1589147 - Handle 64 B USB packets for Smart Card redirection
Summary: Handle 64 B USB packets for Smart Card redirection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Qianqian Zhu
URL:
Whiteboard:
Depends On:
Blocks: 917867
TreeView+ depends on / blocked
 
Reported: 2018-06-08 13:42 UTC by Jakub Jelen
Modified: 2018-11-26 02:23 UTC (History)
20 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:10:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
certificate picture (382.67 KB, image/png)
2018-09-13 12:03 UTC, Li Xiaohui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3443 None None None 2018-11-01 11:12:36 UTC

Description Jakub Jelen 2018-06-08 13:42:41 UTC
Description of problem:
During the implementation of CAC2 in libcacard, we identified issue with handling of packet of specific sizes in qemu.

The change [1] is already reviewed and merged upstream and to my understanding, it is not yet merged in the RHEL. This is needed for the ongoing work to support smart card sharing (described in the bug #917867).

Version-Release number of selected component (if applicable):
current

How reproducible:
deterministic for message of multiplies of 64 B

Steps to Reproduce:
1. Request 32 B data from the smart card emulator, which will add to 64 B on USB packet layer.

Actual results:
USB in guest times out while waiting for the answer from host

Expected results:
USB packet should be delivered

Additional info:
[1] https://github.com/qemu/qemu/commit/8030dca3

Comment 15 Miroslav Rezanina 2018-08-29 03:06:22 UTC
Fix included in qemu-kvm-rhev-2.12.0-12.el7

Comment 26 Jakub Jelen 2018-09-11 08:44:11 UTC
A1: As already pointed out in comment #24 we should be able to verify this bug without the fix for the bug bug #917867.

A2: I don't have RHEL7 testing machine so I am using Fedora versions:

qemu-kvm-2.11.2-2.fc28.x86_64
libcacard-2.5.3-4.fc28.x86_64 --- this is quite the same as in RHEL7

Updating qemu to the latest testing version in Fedora

qemu-kvm-2.11.2-4.fc28.x86_64 -- this has basically only the fix for this bug on top of the previous version

makes also the second command from comment #24 working for me. What output you get from the commands in the comment #24?

Comment 30 Li Xiaohui 2018-09-13 12:03:49 UTC
Created attachment 1483052 [details]
certificate picture

Comment 32 errata-xmlrpc 2018-11-01 11:10:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.