Bug 158943 - openoffice.org missing font dep, crashes
Summary: openoffice.org missing font dep, crashes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-05-27 00:54 UTC by Warren Togami
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-06-10 15:18:10 UTC


Attachments (Terms of Use)

Description Warren Togami 2005-05-27 00:54:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
[root@localhost ~]# oowriter
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org

Version-Release number of selected component (if applicable):
openoffice.org-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. Install minimal install.
2. Install openoffice.org-writer and all deps.
  

Actual Results:  Fails to start because of a missing dep.

Expected Results:  Should start.

Additional info:

Comment 1 Dan Williams 2005-05-27 14:08:57 UTC
Warren, is the fontconfig package installed?

Comment 2 Dan Williams 2005-05-27 14:12:02 UTC
So, fontconfig must be installed unless RPM plays tricks:

openoffice.org-core requires libgtk-x11-2.0.so.0 (gtk2)
gtk2 requires libfontconfig.so.1 (fontconfig)


Comment 3 Warren Togami 2005-05-27 19:22:21 UTC
Yes fontconfig is installed.  Maybe not the fonts...


Comment 4 Caolan McNamara 2005-06-10 11:54:55 UTC
I'll add a require on basic fonts.


Note You need to log in before you can comment on or make changes to this bug.