Bug 15895 - Wrong position of magic-file
Wrong position of magic-file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 19:11 EDT by Enrico Scholz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 11:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-08-09 19:11:34 EDT
When enabling the mod_mime_magic module, the clause

| <IfModule mod_mime_magic.c>
|     MIMEMagicFile share/magic
| </IfModule>

(/etc/httpd/conf/httpd.conf:552) will be evaluated. Effectively it tries to
read `/etc/httpd/share/magic'.  This fails because the magic file is
installed in /etc/httpd/conf/magic.

Either change the MIMEMagicFile entry to this position or let it point to
the more extended /usr/share/magic file.

Because both magic files are having the same purpose, one of them seems to
be superfluously (see #14741 also).
Comment 1 Preston Brown 2000-08-14 11:16:27 EDT
nalin:  Make sure it reads /usr/share/magic.
Comment 2 Nalin Dahyabhai 2000-08-15 16:57:33 EDT
Should be fixed in apache-1.3.12-23 and later.

Note You need to log in before you can comment on or make changes to this bug.