Bug 1589502 - The clipboard does not work on "firefox on wayland"
Summary: The clipboard does not work on "firefox on wayland"
Keywords:
Status: CLOSED DUPLICATE of bug 1585393
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-10 09:46 UTC by Stoian Dan
Modified: 2018-06-25 02:53 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-25 02:53:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Stoian Dan 2018-06-10 09:46:09 UTC
The clipboard does not work on "firefox on wayland".

1. Open "Firefox on Wayland"

2. Copy or cut some content 

3. Try to paste it outside "firefox on wayland" on a application like gedit.

Expected output:
Have the paste

Actual output:
The clipboard is empty


Note that the reverse (from XWayland apps to firefox on wayland) works!

Comment 1 Steven Bakker 2018-06-15 09:01:37 UTC
I can confirm this one. Happens for both page content and the address bar.

Comment 2 Elliott Sales de Andrade 2018-06-25 02:53:19 UTC

*** This bug has been marked as a duplicate of bug 1585393 ***


Note You need to log in before you can comment on or make changes to this bug.