This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 15896 - RFE:pump in 'loader' should increase dhcp timeout
RFE:pump in 'loader' should increase dhcp timeout
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Erik Troan
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 19:39 EDT by bruno
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 14:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bruno 2000-08-09 19:39:03 EDT
when i try to kickstart a compaq 1850r (which has the tlan ethernet chip),
the dhcp request
issued from 'loader' times out.

the problem is the tlan driver takes ~40 seconds to initialize -- the pump
dhcp request
times out much earlier. i hacked the loader code and increased the timeout
which fixed
the problem.

since kickstart is installing a system, i don't see any danger in setting
large timeouts (e.g.,
on the order of 2 or 3 minutes). as a sanity check, the dhcp client from
ISC defaults it's
timeout to 60 seconds (and it's configurable).

i'd like to see this change make it's way back into the red hat loader
source code.
Comment 1 c.m.western 2000-09-08 14:19:08 EDT
I have the same problem (and request), though I am not sure exactly where the fault lies.
When using the 3c59xdriver which reports the following:
3c59x.c:v0.99H 27May00 Donald Becker http://cesdis.gsfc.nasa.gov/linux/drivers/v
ortex.html
eth0: 3Com 3c905B Cyclone 100baseTx at 0xec00,  00:50:04:3d:58:26, IRQ 10
  8K byte-wide RAM 5:3 Rx:Tx split, autoselect/MII interface.
connected via a Cisco Catalyst 2900 Series XL switch it seems that the switch takes
about 45 seconds to recover (sense speed?) whenever the interface is initialised. To get dhcp
to work at all I had to make the following change:

*** dhcp.c      Tue Aug 22 18:38:55 2000
--- /t/ctcmw/pump-0.8.2/dhcp.c  Mon Aug  7 22:57:58 2000
***************
*** 1159,1166 ****
        return chptr;
      }

-     sleep(45);        /* wait for ethernet card to autosense speed etc */
-
      if ((chptr = prepareRequest(&breq, s, intf->device, startTime))) {
        close(s);
        pumpDisableInterface(intf->device);
--- 1159,1164 ----

This may actually be a problem with the card initialisation, as I have also noticed that there can be other problems
during a boot without dhcp, suggesting that the first packet through the interface is garbled. Note that it does 
have something to do with the switch, as the delay is not required if I connect two computers together directly.
Comment 2 Michael Fulbright 2001-09-14 14:26:57 EDT
This appears to be a very isolated problem and we have not received other
reports so it doesn't require any changes.

Note You need to log in before you can comment on or make changes to this bug.