Bug 1589635 - Logging-curator pod can't be running.
Summary: Logging-curator pod can't be running.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Josef Karasek
QA Contact: Anping Li
URL:
Whiteboard:
: 1597130 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-11 03:21 UTC by Qiaoling Tang
Modified: 2018-08-06 13:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
Diff of GH & dist git (918 bytes, patch)
2018-06-12 08:24 UTC, Josef Karasek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:18:17 UTC

Description Qiaoling Tang 2018-06-11 03:21:56 UTC
Description of problem:
Logging-curator pod could't be running after logging deployment.
# oc get pod
NAME                                      READY     STATUS             RESTARTS   AGE
logging-curator-1-j6bhg                   0/1       CrashLoopBackOff   6          8m
logging-es-data-master-ggr3j03z-1-5sc67   2/2       Running            0          7m

# oc logs logging-curator-1-j6bhg
Traceback (most recent call last):
  File "run_cron.py", line 112, in <module>
    ccj.run()
  File "run_cron.py", line 39, in run
    if self.server_ready():
  File "run_cron.py", line 72, in server_ready
    if es.ping():
AttributeError: 'bool' object has no attribute 'ping'

I executed 'oc rollout latest logging-curator', the pod still couldn't be running.

Version-Release number of selected component (if applicable):
openshift v3.10.0-0.64.0
kubernetes v1.10.0+b81c8f8

openshift-ansible-3.10.0-0.64.0.git.20.48df973.el7.noarch

logging-elasticsearch-v3.10.0-0.65.0.0
logging-fluentd-v3.10.0-0.64.0.0
logging-kibana-v3.10.0-0.65.0.0
logging-curator/images/v3.10.0-0.65.0.0

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging
2.
3.

Actual results:
Ansible-playbook ran successfully, logging-curator pod couldn't be running, other pods were running.

Expected results:
All pods could be running.

Additional info:

Comment 1 Qiaoling Tang 2018-06-11 08:55:46 UTC
The cases related to curator are all blocked, so I added the keywords"TestBlocker"

Comment 2 Josef Karasek 2018-06-12 08:24:49 UTC
Created attachment 1450354 [details]
Diff of GH & dist git

Again, files on GH and in dist git are out of sync

Comment 7 Qiaoling Tang 2018-06-13 03:38:01 UTC
According to comment 5, I removed the keyword "TestBlocker".

Comment 9 Peter Ruan 2018-06-13 19:36:03 UTC
Verified with latest puddle
oc v3.10.0-0.67.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-pruan-310-preserve-merrn-1:8443
openshift v3.10.0-0.67.0
kubernetes v1.10.0+b81c8f8



[root@qe-pruan-310-preserve-merrn-1 ~]# oc get pods
NAME                                           READY     STATUS    RESTARTS   AGE
logging-curator-1-8wlwn                        1/1       Running   0          1m
logging-curator-ops-1-ggjw9                    1/1       Running   0          55s
logging-es-data-master-yhjjg0at-1-deploy       1/1       Running   0          32s
logging-es-data-master-yhjjg0at-1-szdcr        1/2       Running   0          29s
logging-es-ops-data-master-w8zmspwv-1-deploy   1/1       Running   0          24s
logging-es-ops-data-master-w8zmspwv-1-gnfmm    1/2       Running   0          21s
logging-fluentd-t5rnq                          1/1       Running   0          44s
logging-kibana-1-jg69r                         2/2       Running   0          1m
logging-kibana-ops-1-thjlq                     2/2       Running   0          1m

Comment 11 errata-xmlrpc 2018-07-30 19:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816

Comment 12 Justin Pierce 2018-08-06 13:01:03 UTC
*** Bug 1597130 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.