Bug 1589646 - foreman-rake katello:regenerate_repo_metadata failed with "NoMethodError: undefined method `in_default_view' for #<Array:0x000000000ce126f0>"
Summary: foreman-rake katello:regenerate_repo_metadata failed with "NoMethodError: und...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-11 05:04 UTC by matt jia
Modified: 2019-06-13 21:26 UTC (History)
7 users (show)

Fixed In Version: tfm-rubygem-katello-3.4.5.75-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1596350 (view as bug list)
Environment:
Last Closed: 2018-08-22 20:07:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Full stacktrace (6.36 KB, text/plain)
2018-06-13 20:20 UTC, Brad Buckingham
no flags Details
task status successful (54.26 KB, image/png)
2018-08-03 10:02 UTC, Kedar Bidarkar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 23943 0 None None None 2018-06-14 15:25:40 UTC
Red Hat Product Errata RHBA-2018:2550 0 None None None 2018-08-22 20:07:47 UTC

Description matt jia 2018-06-11 05:04:11 UTC
Description of problem:

Can't run foreman-rake katello:regenerate_repo_metadata  as it failed with

"NoMethodError: undefined method `in_default_view' for #<Array:0x000000000ce126f0>"

Version-Release number of selected component (if applicable):

6.3.1

How reproducible:

Easy

Steps to Reproduce:

foreman-rake katello:regenerate_repo_metadata

Actual results:

"NoMethodError: undefined method `in_default_view' for #<Array:0x000000000ce126f0>"


Expected results:

No error.

Comment 2 Brad Buckingham 2018-06-13 20:20:35 UTC
Created attachment 1451027 [details]
Full stacktrace

Comment 4 Stephen Benjamin 2018-06-14 15:25:38 UTC
Created redmine issue http://projects.theforeman.org/issues/23943 from this bug

Comment 5 pm-sat@redhat.com 2018-06-14 16:19:33 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 6 pm-sat@redhat.com 2018-06-14 16:19:37 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 7 pm-sat@redhat.com 2018-06-15 00:18:57 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23943 has been resolved.

Comment 11 Kedar Bidarkar 2018-08-03 10:01:08 UTC
[root@sat63-rhel7 ~]# foreman-rake katello:regenerate_repo_metadata
Regenerating 50 repositories.  You can monitor these on task id 2315ebbc-1cec-45ef-b5fc-3eebe40fb342

There was no error upon running the command and  no error in the /v/l/foreman/production.log

VERIFIED with the Sat6.3.3 snap2 build.

Will also attach a screenshot of the task success status shortly.

Comment 12 Kedar Bidarkar 2018-08-03 10:02:47 UTC
Created attachment 1472935 [details]
task status successful

Comment 14 errata-xmlrpc 2018-08-22 20:07:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2550


Note You need to log in before you can comment on or make changes to this bug.