Bug 1589666 - [RFE] gluster-block: logging add config dynamic reloading support
Summary: [RFE] gluster-block: logging add config dynamic reloading support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: OCS 3.11
Assignee: Xiubo Li
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1632821
TreeView+ depends on / blocked
 
Reported: 2018-06-11 06:30 UTC by Xiubo Li
Modified: 2018-10-24 04:54 UTC (History)
10 users (show)

Fixed In Version: gluster-block-0.2.1-27.el7rhgs
Doc Type: Enhancement
Doc Text:
Updates to the gluster-block configuration file are now applied automatically, removing the need to restart the gluster-blockd daemon when any configuration changes are made.
Clone Of:
Environment:
Last Closed: 2018-10-24 04:52:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2987 None None None 2018-10-24 04:54:38 UTC

Description Xiubo Li 2018-06-11 06:30:29 UTC
Description of problem:

Currently, after the configurations /etc/sysconfig/gluster-blockd of gluster-blockd daemon are changed, we must restart the gluster-blockd daemon to make it work.

Here we need one way to reconfig this without restaring the daemon.
It will be as simple as possible, just:
1, open the config file
2, change it
3, close

That's all.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 9 Anjana KD 2018-10-11 05:17:43 UTC
Updated Doc Text in Doc Text field. kindly verify.

Comment 11 Anjana KD 2018-10-12 06:03:07 UTC
updated the changes

Comment 13 errata-xmlrpc 2018-10-24 04:52:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2987


Note You need to log in before you can comment on or make changes to this bug.