Bug 1589765 - Volume deleted but still shows up on the Grafana dashboard
Summary: Volume deleted but still shows up on the Grafana dashboard
Keywords:
Status: CLOSED DUPLICATE of bug 1518610
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1574938
TreeView+ depends on / blocked
 
Reported: 2018-06-11 11:06 UTC by Filip Balák
Modified: 2018-06-12 07:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-12 07:14:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dashboard with deleted volume (87.28 KB, image/png)
2018-06-11 11:06 UTC, Filip Balák
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1516672 None CLOSED Volume deleted but still shows up on the Grafana dashboard (With a white background) 2019-02-27 09:08:57 UTC

Internal Links: 1516672

Description Filip Balák 2018-06-11 11:06:13 UTC
Created attachment 1449957 [details]
Dashboard with deleted volume

Description of problem:
Volume name stays on grafana Volume and Brick dashboards when it is deleted.

Version-Release number of selected component (if applicable):
tendrl-ansible-1.6.3-4.el7rhgs.noarch
tendrl-api-1.6.3-3.el7rhgs.noarch
tendrl-api-httpd-1.6.3-3.el7rhgs.noarch
tendrl-commons-1.6.3-6.el7rhgs.noarch
tendrl-grafana-plugins-1.6.3-4.el7rhgs.noarch
tendrl-grafana-selinux-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.6.3-4.el7rhgs.noarch
tendrl-node-agent-1.6.3-6.el7rhgs.noarch
tendrl-notifier-1.6.3-3.el7rhgs.noarch
tendrl-selinux-1.5.4-2.el7rhgs.noarch
tendrl-ui-1.6.3-3.el7rhgs.noarch

How reproducible:
100%

Steps to Reproduce:
1. Import cluster into WA.
2. Created volume in the cluster. This can be done before or after import.
3. Wait until there is information about the volume in grafana.
4. Delete volume:
gluster volume <volume-name> stop
gluster volume <volume-name> delete
5. Open volume and brick grafana dashboards.

Actual results:
The volume is still listed listed as Volume Name option.

Expected results:
The volume should be removed from Grafana.

Additional info:

Comment 2 Filip Balák 2018-06-12 07:14:51 UTC

*** This bug has been marked as a duplicate of bug 1518610 ***


Note You need to log in before you can comment on or make changes to this bug.