Bug 158984 - ImageMagick links to libdps, which is obsoleted
ImageMagick links to libdps, which is obsoleted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-27 10:12 EDT by Mike A. Harris
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 14:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2005-05-27 10:12:28 EDT
Description of problem:

X.Org is obsoleting libdps, libdpstk, libpsres in X11R7, which means these
libraries will be officially removed from the OS for FC5.  The only things
that link to DPS in the entire OS, are things that come with X itself,
which are DPS utilities and test apps, and ImageMagick.  The X server does
not even support DPS, so generally speaking -> DPS support is useless.

Since we have never had an X server that supports DPS, and Xorg is killing
this client library, please rebuild Imagemagic with "--disable-dps" as soon
as possible, preferably even for FC4 so people who are using FC4 who try
to update to the upcoming X11R7 release, wont have dependancy problems
due to a single package.

This will help to ease the growing pains we face when switching to X11R7.

Thanks in advance.
Comment 1 John Robinson 2005-08-27 14:42:18 EDT
I can't comment on how useless DPS support may or may not be, but generally I'd
like to second the request to change the ImageMagick build. libdps etc. perhaps
ought to be in xorg-x11-deprecated-libs for X.Org 6.9, but they probably won't
make it into X.Org 7.0 at all. If you do change the ImageMagick build, the
option is "--without-dps" or "--with-dps=no". Also, if there are any other
packages in Fedora Core which depend on ImageMagick, they may need rebuilding (I
found my 3rd-party xine-lib depended on libdps because it uses ImageMagick). I
came across this when testing a set of xorg 6.8.99 rpms so the reporter's
concerns are fair :-)
Comment 2 Mike A. Harris 2005-08-29 02:25:43 EDT
libdps and libdpstk are officially obsolete in upstream X.Org CVS currently,
and are not built by default.  They will not be in the X11R7 release, nor
in Fedora Core 5.

Any software which currently is linking to libdps, needs to be compiled
without DPS support from now on.  Once we put X11R7 release candidate
into rawhide, anything linking to libdps will no longer build, so it
is a good idea to disable dps support before then to minimize problem
load later.

Thanks in advance.


P.S.  XFree86 and X.Org X servers have never supported the server side
DPS extension.  There is http://dps.sf.net project which attempted to
implement DPS server-side, but it was never shipped by anyone, and the
project has long since been discontinued.  X server side DPS support is
only available in ancient proprietary X servers, so is of little use
to the open source community in general.

Note You need to log in before you can comment on or make changes to this bug.