Bug 1589841 - Kubevirt-apb needs an explicit reference to the hosts file /etc/ansible/hosts
Summary: Kubevirt-apb needs an explicit reference to the hosts file /etc/ansible/hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.z
Assignee: Ryan Hallisey
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-11 13:46 UTC by Ryan Hallisey
Modified: 2018-07-30 19:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:18:17 UTC

Description Ryan Hallisey 2018-06-11 13:46:25 UTC
Without the explicit reference, the hosts file never get noticed.

PLAY [masters[0]] **************************************************************
skipping: no hosts matched
 [WARNING]: Could not match supplied host pattern, ignoring: masters
 [WARNING]: Could not match supplied host pattern, ignoring: nodes

PLAY [masters nodes] ***********************************************************
skipping: no hosts matched

PLAY RECAP *********************************************************************
localhost                  : ok=15   changed=8    unreachable=0    failed=0   


Upstream PR: https://github.com/ansibleplaybookbundle/apb-base/pull/31

Comment 2 Zhang Cheng 2018-06-15 01:31:31 UTC
@Ryan,

I hope double confirm with you what is the target release you want, currently is "3.10". Thanks.

Comment 3 Ryan Hallisey 2018-06-15 19:36:38 UTC
Yes

Comment 6 Zhang Cheng 2018-06-22 06:30:52 UTC
Ryan, How to reproduce this issue? Can I use the four downstream apbs (in Stage registry) to recreate?

BTW, Kubevirt-apb is not a downstream apb.

Comment 7 Ryan Hallisey 2018-06-22 11:17:47 UTC
The kubevirt-apb downstream build is old.  Working on a new one and will link it.

Comment 8 Zhang Cheng 2018-06-25 02:46:26 UTC
Changing status to Modify since not ready for test in currently.

BTW, as I know, kubevirt-apb still is a upstream image in docker-hub, and we have no plan to ship in downstream in OCP3.10

Ryan, it will effect all four downstream images if your fix in apb-base. And for verification, Could you help to provide more detail steps? Thanks.

Comment 9 Ryan Hallisey 2018-06-27 11:27:30 UTC
Just got a downstream build for kubevirt-apb https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=16878951

Run the apb just like any other apb.  It should successfully deploy kubevirt-api, virt-controller, virt-handler, and containerized-data-importer.

Comment 11 Ryan Hallisey 2018-07-11 06:34:49 UTC
Latest build: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=17104999

Comment 12 Ryan Hallisey 2018-07-11 06:35:37 UTC
Upstream image ansibleplaybookbundle/kubevirt-apb:v0.7.0 is working.  Just completed a build downstream with the source.

Comment 13 Zhang Cheng 2018-07-11 09:26:29 UTC
Changing status to ON_QA since image ready for test.

Comment 18 Ryan Hallisey 2018-07-16 15:45:22 UTC
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=725314

New build.  Confirmed it has the expected content.

Comment 20 Ryan Hallisey 2018-07-23 13:11:46 UTC
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=17236807

docker pull brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/cnv11-tech-preview/kubevirt-apb:1.1

New build worked for me.

Comment 23 Zhang Cheng 2018-07-24 07:18:27 UTC
I changing status to "Assigned" base on above comments. Please correct me if I have some mistake. Thanks.

Comment 24 Ryan Hallisey 2018-07-24 10:44:30 UTC
Can you re-test with a cluster-admin user? and registry URL=brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888

Comment 26 Zhang Cheng 2018-07-24 12:04:56 UTC
virt-api,virt-controller and virt-handler running well after using correct "registry URL" and "registry namespace" while provisioning.

There are two issues for Kubevirt-apb for me.
1. It does not support cri-o env, detail refer to comment 22
2. Default registry URL is "docker.io" in currently.

I can mark this bug to verified if you think above two are by expected or will not fix in this bug.

Comment 27 Ryan Hallisey 2018-07-24 12:27:12 UTC
I think it's verified.  I'll look into the cri-o issue and changing the default url. Thanks.

Comment 28 Zhang Cheng 2018-07-24 13:04:43 UTC
Base on comment 22, comment 26 and comment 27, changing status to Verified.

Comment 30 errata-xmlrpc 2018-07-30 19:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.